User Guide

*Purpletree Multi-Vendor Marketplace for Opencart*
# Table of Contents

FAQ ............................................................................................................................................ 6
Installation ..................................................................................................................................... 12
   Installation for Opencart version 2.x ..................................................................................... 12
   Installation for Opencart version 3.x ..................................................................................... 22
Upgrade Instructions .................................................................................................................. 34
Context Sensitive Help .............................................................................................................. 36
Basic Usage Instructions .......................................................................................................... 38
Hide customers Details from sellers ....................................................................................... 52
Hide Seller Registration fields ................................................................................................. 54
Seller Account Terms ................................................................................................................ 57
Frontend side .............................................................................................................................. 60
   Seller Vacation mode ............................................................................................................ 75
   Quick Edit Seller product .................................................................................................... 80
   Smart product form .............................................................................................................. 81
Working with Advanced Shipping Module ............................................................................... 91
   Configuring Multivendor Advanced Shipping .................................................................... 91
   Add/Edit shipping rate for product from Admin Panel .......................................................... 93
   Add/Edit shipping rate for product from Seller Panel .......................................................... 94
   Defining Shipping Rates from Admin Panel ........................................................................ 96
   Defining Shipping Rates from Seller Panel ........................................................................ 98
   Configuring Advanced Shipping for seller products via Admin Panel .............................. 98
   Configuring Advanced Shipping for seller products via Seller Panel .............................. 99
   Shipping Rates Bulk import via Admin Panel ...................................................................... 100
   Shipping Rates Bulk import via Seller Panel ...................................................................... 102
   Enable Purpletree shipping module .................................................................................... 103
   Create geo zone shipping by admin ...................................................................................) 106
   Configuring Advanced Shipping for seller products via Admin Panel .............................. 108
   Configuring Advanced Shipping for seller products via Seller Panel .............................. 109
   Create geo zone shipping by Seller ..................................................................................... 110
   Product Bulk Upload .......................................................................................................... 112
Product Bulk Upload from Admin Panel .............................................................................. 112
Product Bulk Upload from Seller Panel ............................................................................. 114
Template Products ............................................................................................................ 123
Managing Downloadable Product via Seller Panel .......................................................... 135
Live Chat Module ............................................................................................................. 139
Admin Configuration ......................................................................................................... 139
Seller side configuration ..................................................................................................... 143
Customer Enquiries module .............................................................................................. 144
Admin settings .................................................................................................................. 144
Delete all information of seller .......................................................................................... 145
Customer Side ................................................................................................................... 146
Seller Side .......................................................................................................................... 153
Subscription Plan module ................................................................................................. 155
Admin settings .................................................................................................................. 155
Add default currency for Subscription plan payment ....................................................... 157
Adding Subscription Plans ............................................................................................... 157
Admin Invoice Status of subscription Plan ...................................................................... 159
Seller Pending Subscription Invoices ............................................................................ 161
Admin Seller Subscription ............................................................................................... 161
Multiple Subscription Plans ............................................................................................. 168
Admin settings .................................................................................................................. 168
Subscription plan’s products, featured and category featured products ....................... 170
Admin Side ......................................................................................................................... 170
Assign Subscription plan to product from Store edit ....................................................... 171
Subscription Plan Seller Side ............................................................................................ 172
View Invoice ...................................................................................................................... 174
Subscription Invoices ........................................................................................................ 176
Product Limit ..................................................................................................................... 176
Cron Setup for Seller Subscription .................................................................................. 177
Multiple Subscription Plans ............................................................................................. 177
Subscription Plan’s Products, Featured and Category Featured Products ....................... 178
Seller Side .......................................................................................................................... 178
Automatic SEO options .................................................................................................... 181
Restricting No. of categories allowed for single product ................................................ 182
Featured Stores .................................................................................................................. 184
Steps to configure and use Featured Stores ................................................................. 184
  Enabling the Module ................................................................................................. 184
Display latest products from sellers in a carousel ....................................................... 189
Seller Details module ................................................................................................. 192
  Enabling the Module ................................................................................................. 192
Email Templates .......................................................................................................... 195
Managing Featured Products ....................................................................................... 199
  Enabling the module ................................................................................................. 199
Adding featured products in subscription plans .......................................................... 201
Adding product to featured carousel by seller .............................................................. 202
Featured products for category page ............................................................................ 206
  Enabling the module ................................................................................................. 206
Seller side management .............................................................................................. 208
Admin side management for Category Featured Products .......................................... 211
Sellers Blogs ................................................................................................................ 213
  Enabling the module ................................................................................................. 213
Managing Blogs as Admin ......................................................................................... 217
Managing Blogs as a Seller ....................................................................................... 220
Frontend view of Blogs .............................................................................................. 223
  Blog List ................................................................................................................... 223
  All Blog Post ............................................................................................................. 223
  Single Blog Post ....................................................................................................... 224
Handling Commissions & Commission Invoices ....................................................... 225
  Commission Invoice Details ..................................................................................... 225
Multivendor Paypal Payout for Split Payment ............................................................. 231
  How to Configure Multivendor PayPal Payout Payment Method ............................. 231
  How to Update Paypal Payout Status ...................................................................... 234
Using Stripe Direct Payments for Vendors ............................................................... 236
Product Returns .......................................................................................................... 243
  Return request view for seller ................................................................................... 245
  Admin side process for return .................................................................................. 247
  Seller side process for return .................................................................................. 254
  Customer side process for return ............................................................................ 255
Seller Discount Coupons ............................................................................................. 257
Setting Commission for Seller Groups ....................................................................... 261
Fixed Commission .................................................................................................................. 264
How fixed global commission works ................................................................................. 264
Category commission ........................................................................................................... 264
Seller store commission ....................................................................................................... 264
Global commission ............................................................................................................... 264
Commission Invoice ........................................................................................................... 264
Seller & admin Message system ......................................................................................... 265
Seller Notification of Orders and customer Enquiries ......................................................... 270
Opencart Multi-Store Support ............................................................................................. 273
1. When domain-wise-stores setting is Disabled ............................................................... 273
2. When domain-wise-stores setting is Enabled ............................................................... 273
Seller product Attribute ...................................................................................................... 276
Seller product Attribute Groups .......................................................................................... 277
Seller product Options ........................................................................................................ 277
Seller product Attribute Groups .......................................................................................... 279
Adding Seller custom fields ............................................................................................... 279
Hiding seller information for products ................................................................................. 284
Hiding seller information on order success page ............................................................... 285
Seller order status changed by customer ............................................................................ 286
Hyperlocal Feature ............................................................................................................. 288
Assigning areas to sellers from Admin ............................................................................... 288
How sellers can assign Areas ........................................................................................... 289
Selecting area at the time of seller registration .................................................................. 290
Configuring Hyperlocal options ........................................................................................ 291
Area Display at Homepage ................................................................................................. 292
Support ............................................................................................................................... 296
FAQ

1. **I am facing an issue. How do I get technical support?**
   
   If you face any issues, please open a support ticket on https://www.helpdesk.purpletreesoftware.com with following information:
   
   a) Order Id
   b) Website URL
   c) Opencart Admin URL
   d) **Opencart Admin username and password**
   e) **cPanel credentials** (cPanel URL, Username, Password) or **FTP credentials** (hostname, username, password, port) with access to all directories including Opencart storage directory (make sure the user has access to Opencart storage directory, otherwise it may not be possible to analyze)

2. **Which versions of Opencart are supported?**
   
   We support version 2.3 onwards, meaning version 2.3.x and 3.x.

3. **I did not get my license key.**
   
   Usually license key is automatically sent sometime after purchase, on the email id of the extension purchaser. If you still haven't received it, please open a ticket with us from https://helpdesk.purpletreesoftware.com.

   Or

   Go to Admin > Multivendor > Setting > General tab > Click on “Change License Key” > Don’t Have License Key” button. Enter your Order ID which was generated when you placed an order for our extension and “Email ID”. Click on Submit Button and your license key will be filled on License key field.
4. **My license key does not work.**  IMP

This could be because of violation of licensing policy. You can check the section 05 of license policy from [here](#). Also, you can view your license usage from [this page](#).

5. **Does your extension support my theme?**

This extension is designed to work with any standard Opencart theme. This means, any page in the website will not break because of our extension. The design of Seller’s Store page comes from our extension in default design, not from the theme.

6. **Does this extension support multiple languages?**

This extension provides full support for following languages, i.e., these languages are built in. You need not do anything to have Multivendor related text appearing in these languages. Just change the language from admin settings, and you are done.

1. English
2. Arabic
3. Spanish
4. French
5. German
6. Dutch
7. Italian
8. Chinese (China)
9. Chinese (Taiwan)
10. Portuguese
11. Indonesian
12. Japanese
13. Russian
14. Filipino
15. Vietnamese
16. Thai
17. Malaysian
18. Romanian
7. **When and how is the commission calculated?**

**WHEN:**

Commission is calculated when the order status is set to a predefined status, on which admin wants commission to be calculated. See the image below.

For commission to be applied for order each seller order must be completed (or as in configuration below). And after that when admin change the status of the main order to complete (or as in configuration below), then only commission will calculate or re-calculate for only those sub orders of the seller whose order status is complete (or as in configuration below).

This status value can be set in extension options:

![Image](image_url)

**HOW:**

Commission can be set based on 3 criteria:

a) Commission on per category basis – applicable to all products in a category  
b) Commission on per seller basis – applicable to all products of a seller  
c) Commission on global basis – applicable to all products in store  

Order of commission calculation is a -> b -> c. This means commission from category is checked very first. If any product has commission set for its category, it is applied. In case products falls in more than one category having commission, maximum value of commission is selected.

If category commission is not defined, then system looks for commission of the seller for product. If that is also not defined, global commission value is applied.

8. **How do I handle shipping charges?**

We have developed a shipping module which is part of this extension. Install and configure it as per instructions given in this guide.

9. **Which payment gateways can be used?**

Customers can use any payment gateway for making orders.
For making payment to sellers from admin side, we support PayPal and offline mode.

We also have Multivendor PayPal Payments Payouts method, and Stripe Connect Payouts, in which case the payment goes to seller and admin both simultaneously at the time of customer order.

10. **How do I settle payments with sellers?**

Admin collects all payment in the store using payment gateway of his/her choice. Seller gets payment from admin later on, probably once in a week or month. This is called settlement. Settlement entries can be captured in system.

The payment modes are Offline and PayPal for settlements with sellers.

For settling payments from admin to sellers, following is the procedure:

Make sure all orders have been completed, first by seller and then by admin.

Admin has to create commission invoice for the orders of the seller.

Admin can make payout for the pending amount towards the vendor from the commission invoice.

Payouts are made for every commission invoice. This means, if the order amount was 100 USD, and commission was 20 USD, the payout of 80 USD can be made from inside the commission invoice itself. This helps in keeping track of the payout made, on per invoice basis.

Payment to sellers can be made by PayPal and Offline mode.

In case of Multivendor PayPal Payout payment method, and Stripe Payout method, the payment goes to seller and admin both simultaneously at the time of customer order. In this case, there is no need of settlement, as the amounts are calculated and settled into respective accounts of sellers and admin. Admin just need to update the Payout status only if Payout was not successful or awaiting approval.

PayPal Authorization - You need to contact PayPal and ensure that you have BULK PAYOUTS enabled. That must be enabled by PayPal from their end. Once done, it should work.

11. **How are discounts and taxes handled?**

Discounts and Taxes are configured in core Opencart website, not in our extension. So, this data is not reflected in our extension.

12. **Why there are different values for order status in seller panel and admin panel?**

An order can have products involving many sellers. While a seller can manage order status, he/she must not be able to do that for the entire order, because there are other sellers also whose status can be different. For this reason, each seller manages own order status. The final order status value remains to be managed by admin.

From Admin->Manage Seller Orders, Admin can view product name along with Store from which it is orders, then there is Status - This is Seller Status of his part order. Shipping Charge for each seller order, then comes **Admin Status** – this is the full order status set by admin.
There are 2 columns in Seller Orders in Seller Panel, first status column shows seller order status and Admin Status shows admin order status.

13. **How to check the version of the extension installed?**

Go to Left menu in admin, Multivendor ->Settings

On bottom of this page, version of the extension is mentioned.
14. **I cannot see “Seller Login” and “Browse Sellers” links on the header of my website.**

It is possible that due to different coding in your theme files, the links are not inserted by our extension. In that case, you can easily insert these links using this step: 8.

15. **What is the difference between a Seller and a Customer?**

Seller is also a normal Opencart user like a customer, albeit with more functions available, from seller panel. Registration and login pages and dashboard pages are different for seller and customers. Seller can access the account as a customer also, from customer login page.
Installation

**Important:** Before installation, make sure the Opencart Extension Installer is correctly configured, especially the FTP settings, including the FTP Root. See http://docs.Opencart.com/extension/installer for more details.

**Installation for Opencart version 2.x**

1. Go to “Extensions” -> “Extension Installer”.

2. Upload the file Multivendor.ocmod.zip.

3. Go to “Extensions” -> “Modifications”. You should see an entry for this – “Purpletree Multivendor for Opencart 2.x”.
4. Click on the Refresh button, on top right of the page, as shown below.

5. Now go to 'Extensions-> Extensions' and select 'Module'. Check for the 'Multivendor settings.'
Now, Click on Green button (shown as 1 above) to install the module. Now we need to give permission for the module to Administrators of the store.

6. Go to “System -> Users -> User Group > Edit Administrator” as shown below.
7. Set access and modify permissions for all Purpletree related modules, like
   - extension/module/Purpletree_featuredstore
   - extension/module/Purpletree_latestseller_products
   - extension/module/Purpletree_Multivendor
   - extension/module/Purpletree_sellerblog
   - extension/module/Purpletree_sellerfeatured
• extension/module/Purpletree_sellerpanel
• extension/module/Purpletree_sellerprice
• extension/payment/pp_adaptive
• Purpletree_Multivendor/SubscriptionplanInvoice
• Purpletree_Multivendor/admintemplate
• Purpletree_Multivendor/bulkproductupload
• Purpletree_Multivendor/bulkshippingupload
• Purpletree_Multivendor/categoriescommission
• Purpletree_Multivendor/commissioninvoice
• Purpletree_Multivendor/geozone
• Purpletree_Multivendor/managesubscriptionplan
• Purpletree_Multivendor/offlinepaymentform
• Purpletree_Multivendor/planningvoicestatus
• Purpletree_Multivendor/producttemplate
• Purpletree_Multivendor/sellerblogcomment
• Purpletree_Multivendor/sellerblogpost
• Purpletree_Multivendor/sellercommission
• Purpletree_Multivendor/sellercontacts
• Purpletree_Multivendor/sellercustomfield
• Purpletree_Multivendor/selleremail
• Purpletree_Multivendor/sellerenquiries
• Purpletree_Multivendor/sellerorders
• Purpletree_Multivendor/sellerpayment
• Purpletree_Multivendor/sellerproducts
• Purpletree_Multivendor/sellerreviews
• Purpletree_Multivendor/shipping
• Purpletree_Multivendor/stores
• Purpletree_Multivendor/subscriptionplan
• Purpletree_Multivendor/subscriptionplan_pendinginvoice
• Purpletree_Multivendor/upgradedatabase
• Purpletree_Multivendor/vendor
• extension/shipping/Purpletree_shipping
8. Click on blue EDIT button (shown as 2 above) and enter configuration parameters.
### Multivendor Settings

#### General
- **Enabled**

#### Vendor settings
- **Admin order status for commission calculation**
  - Complete
- **Status of returns for refund calculation**
  - Refunded
- **Shipping Type**
  - No Code Shipping
- **Fixed Commission**
  - N/A
- **Shipping Commission (as percent)**
  - N/A
- **Commission from seller group**
  - N/A
- **Commission invoice footer text**
  - N/A
- **Allow seller to manage orders**
  - Yes
- **Allow order status for seller/customer**
  - Cancelled, Reversed, Complete, Open, Expired, Failed
- **Allow shows seller panel to users**
  - Allow Messages, Customer Enquiries, Subscription Plan, No links, Downloads
- **Allow customer to manage orders**
  - Yes
- **Seller approval required**
  - Yes
- **Product approval required**
  - Yes
- **Allow category for seller**
  - Allow all categories
- **No. of Categories allow for a single product**
  - N/A
- **Show seller logo / seller panel list**
  - Yes
- **Enable two-way chat**
  - Yes
- **Enable Browser session**
  - Yes
- **Wide User Menu for sellers**
  - Yes
- **Use domain wise stores**
  - Yes
Here set the status to ‘Enabled’, and make following configuration changes:

Click on “Change License Key” button. Enter License key – This key is provided when you purchase the extension. Click on Ok Button

Or

Go to Admin > Multivendor > Setting > General > Change License Key > “Don't Have License key” button. Enter your Order ID which was generated when you placed an order for our extension and “Email ID”. Click on Submit Button and your license key will be filled on License key field.

1. General Tab
   a. Admin Status for which Commission will calculate – Commission of the order will be calculated only when this status is set for seller order and then for main order.
   b. Admin Action for which Refund will calculate – Refund of the order will be done only when this Action set for seller refund order and for main refund order.
   c. Shipping Type – Admin can set default Purpletree Shipping like Zip Code Shipping or Geo Zone Shipping.
   d. Commission – This commission is applied to all seller products, unless there is different commission value present for individual seller.
e. Shipping Commission - *This commission is applied to all seller products shipping cost.*

f. Commission from seller group – if set to yes, category commission is applied to all seller

g. Commission Invoice Footer text –Whatever text is given by admin. The text will appear below of subscription plan invoice.

h. Allow seller to manage orders - *if set to yes, sellers can process their part of orders.*

i. Allow order status for seller/customer – *Select Order Status from Multiselect for Seller or customer which order status can be changed by Seller or Customer*

j. Allow customer to manage orders – *Select Yes if you want customer to manage Orders, else select No.*

k. Allow seller to manage orders- if set to yes, then the sellers can manage their products.

l. Seller approval required – *if set to yes, admin must approve a seller before the seller can use seller panel.*

m. Product approval required – *if set to yes, admin must approve every product added by sellers.*

n. Allow category for seller – *choose either all categories, or selected categories here, where sellers can upload products.*

o. No. of categories allow for a single product- if his is set to Multiple, then the seller can assign multiple categories to a single product. If this is set to Single, then seller can assign one category to a particular product

p. Show Seller Login / Seller Panel Link - *if this is set to yes, “Show Seller Login / Seller Panel Link” appears on homepage(header).*

q. Allow Tawk.to Live Chat- if this is set to yes, then customers can enquire to seller for any kind of information.

r. Enable Browse Sellers- if this is set to yes, then the browse seller link will be visible on the top of website. Hide User Menu for sellers –if this is set to yes, then the only seller panel will visible on account page.

s. Hide User Menu for sellers --if this is set to yes, “User Menu” not appears on all seller pages.

2. Seller Tab

   a. Show seller information on order success page – *Select Yes to show Seller Name and Address on Order Success Page for Seller products.*
b. Show seller name on product list - Select Yes to show Seller name on Product in Product listing on all modules and Category page.

c. Show seller address on product list - Select Yes to show Seller Address on Product in Product listing on all modules and Category page.

d. Hide seller detail on product page – Hide Seller details on product page Select Yes or Select No Show Seller Details on Product page.

e. Show sellers on category page – Select Modes from Dropdown here. Normal Mode will do nothing, Category Mode will show Sellers on category pages instead of Products or Select Services Mode

f. Seller Store Page Layout - this sets default seller store layout like Layout 1 and Layout 2.

g. Products View – Show List or Grid from dropdown on Seller Products listing page on seller side.

h. Use Smart Product Form - if this is set to yes, then the general and data tab only visible on seller product page other tab will be hide.

i. Allow seller’s to reply customers – if this is set to yes, then the seller can reply customer enquiry message.

j. Use Product Templates - if this is set to yes, sellers can use Product Templates to make new product.

k. Allow seller to add related product – if this is set to yes, sellers can add related products for their products

l. Featured enabled hide edit button – if this is set yes, sellers can’t edit featured products.

m. Allow Seller’s Featured Products - if this is set yes, Seller’s featured product column hide on product list page on seller side.

n. Allow Seller’s Category Featured Products – if this is set yes, Seller’s Category Featured Products column hide on product list page on seller side.

o. Max. Number of seller products allowed in cart – this sets maximum number of products a customer can order, for seller products.

p. Seller review enabled - if set to yes, users can review sellers also, in addition to usual product reviews.
q. Seller contact mode - *if set to general*, then the only seller panel will visible on account page.

r. Sort by- *if set to create date*, then the blog will visible according to create date means in the form of descending.

s. Fields to show- if admin has check the Seller name, Store email, Store phone, Store address, Social Links then information will visible on store view page.

t. Invoice/shipping generated by seller-*if set to yes*, then the seller can generate invoice/shipping. If set NO, then you can also hide customer details for sellers.

3. Subscription Tab: -
   a. Enable Subscription Plans- *if set to yes*, then the subscription plan will enable for seller after that some fields will be visible then you can configure according to your need.

4. Development Tab: -
   a. Include jQuery- *if set to yes*, then the Purpletree jQuery file will include.

5. Registration
   a. From this tab you can hide seller registration fields for sellers.

Now click on the ‘Save’ button on the upper right corner. This completes basic configuration.
Installation for Opencart version 3.x

1. Go to “Extensions” -> “Installer”.

![Installer screenshot]

2. Upload the file named similar to *Opencart-Multivendor.3.x.ocmod.zip*.

3. Now upload the file named similar to *Multivendor-extras-oc3.x.ocmod.zip*.

4. Go to “Extensions” -> “Modifications”. You should see an entry for this – “Purpletree Multivendor for Opencart 3.x”.

![Modifications screenshot]

5. Click on the Refresh button, on top right of the page as shown below.
6. Now go to 'Extensions-> Extensions' and select 'Module'. Check for the Multivendor settings.
Now, Click on Green button (shown as 1 above) to install the module. Now we need to give permission for the module to Administrators of the store.

7. Go to “System -> Users -> User Group > Edit Administrator” as shown below.

8. Set access and modify permissions for
   - extension/module/Purpletree_featuredstore
   - extension/module/Purpletree_latestseller_products
   - extension/module/Purpletree_Multivendor
   - extension/module/Purpletree_sellerblog
   - extension/module/Purpletree_sellerfeatured
   - extension/module/Purpletree_sellerpanel
   - extension/module/Purpletree_sellerprice
   - extension/payment/pp_adaptive
   - extension/Purpletree_Multivendor/SubscriptionplanInvoice
   - extension/Purpletree_Multivendor/admintemplate
   - extension/Purpletree_Multivendor/bulkproductupload
   - extension/Purpletree_Multivendor/bulkshippingupload
   - extension/Purpletree_Multivendor/categoriescommission
   - extension/Purpletree_Multivendor/commissioninvoice
   - extension/Purpletree_Multivendor/geozone
- extension/Purpletree_Multivendor/managesubscriptionplan
- extension/Purpletree_Multivendor/offlinepaymentform
- extension/Purpletree_Multivendor/planningvoicestatus
- extension/Purpletree_Multivendor/producttemplate
- extension/Purpletree_Multivendor/sellerblogcomment
- extension/Purpletree_Multivendor/sellerblogpost
- extension/Purpletree_Multivendor/sellercommission
- extension/Purpletree_Multivendor/sellercontacts
- extension/Purpletree_Multivendor/sellercustomfield
- extension/Purpletree_Multivendor/selleremail
- extension/Purpletree_Multivendor/sellerenquiries
- extension/Purpletree_Multivendor/sellerorders
- extension/Purpletree_Multivendor/sellerpayment
- extension/Purpletree_Multivendor/sellerproducts
- extension/Purpletree_Multivendor/sellerreviews
- extension/Purpletree_Multivendor/shipping
- extension/Purpletree_Multivendor/stores
- extension/Purpletree_Multivendor/subscriptionplan
- extension/Purpletree_Multivendor/subscriptionplan_pendinginvoice
- extension/Purpletree_Multivendor/upgradedatabase
- extension/Purpletree_Multivendor/vendor
- extension/shipping/Purpletree_shipping
9. Click on blue EDIT button (shown as 2 above) and enter configuration parameters.
### Multivendor Settings

#### General
- **Status**: Enabled

#### Vendor settings
- **Admin order status for commission calculation**: 
  - **Completed**: No
  - **Rejected**: No
- **Shipping Type**: 
  - **Flat Rate**: No
- **Vendor Commission**: 
  - **Percentage**: No
- **Allow seller to message orders**: No
- **Allow order status for seller/customer**: 
  - **Cancelled**: Yes
  - **Canceled Reversal**: Yes
  - **Chargeback**: Yes
  - **Completed**: Yes
  - **Delayed**: Yes
  - **Deleted**: Yes
  - **Failed**: Yes
- **Show Dashboard Seller Panel Icons**: 
  - Yes
- **Allow customer to message orders**: Yes
- **Product approval required**: Yes
- **Category for seller**: 
  - **All categories**: Yes
- **No of categories allow for a single product**: Yes
- **Show Seller Login/Seller Panel Link**: Yes
- **Allow Team Or Live Chat**: Yes
- **Enable Reviews Sellers**: Yes
- **Hide User Menu for sellers**: Yes
- **Use domain wise store**: Yes

---

**Version 3.17.12**

OpenCart © 2005-2022 All Rights Reserved. Version 3.1.3.2
Here set the status to ‘Enabled’, and make following configuration changes:

Click on “Get License” button. Enter License Key – This key is provided when you purchase the extension.

Or

Go to Admin > Multivendor > Setting > Click on “Don't Have License key” button. Enter your Order ID which was generated when you placed an order for our extension and “Email ID”. Click on Submit Button and your license key will be filled on License key field.

10. General Tab
   a. Admin Status for which Commission will calculate – Commission of the order will be calculated only when this status is set for seller order and then for main order
   b. Admin Action for which Refund will calculate – Refund of the order will be done only when this Action set for seller refund order and for main refund order
   c. Shipping Type – Admin can set default shipping like Zip Code Shipping or Geo Zone Shipping.
d. Commission – *This commission is applied to all seller products, unless there is different commission value present for individual seller.*

e. Shipping Commission - *This commission is applied to all seller products shipping cost.*

f. Commission from seller group – if set to yes, category commission is applied to all seller

g. Commission Invoice Footer text –Whatever text is given by admin. The text will appear below of subscription plan invoice.

h. Allow seller to manage orders - *if set to yes, sellers can process their part of orders.*

i. Allowed order status while updating order status, for seller/customer – Choose either all order status, or selected order status here, would be shown on *change order status* dropdown on the order information page, on seller side and customer side.

![Allow order status for seller/customer](image)

j. Allow customer to manage orders - *if set to yes, sellers can process their part of orders.*

k. Seller approval required – *if set to yes, admin must approve a seller before the seller can use seller panel.*

l. Product approval required – *if set to yes, admin must approve every product added by sellers.*

m. Allow category for seller – *choose either all categories, or selected categories here, where sellers can upload products.*

n. No. of categories allow for a single product- if his is set to Multiple, then the seller can assign multiple categories to a single product. If this is set to Single, Then seller can assign one category to a particular product.

o. Show Seller Login / Seller Panel Link - *if this is set to yes, “Show Seller Login / Seller Panel Link” appears on home page(header).*
p. Allow Tawk.to Live Chat - if this is set to yes, then customers can enquire to seller for any kind of information.

q. Enable Browse Sellers - if this is set to yes, then the browse seller link will be visible on the top of website. Hide User Menu for sellers – if this is set to yes, then the only seller panel will be visible on account page.

r. Hide User Menu for sellers – if this is set to yes, “User Menu” not appears on all seller pages.

11. Seller Tab:
   a. Seller Store Page Layout - this sets default seller store layout like Layout 1 and Layout 2.
   b. Use Smart Product Form - if this is set to yes, then the general and data tab only visible on seller product page another tab will be hidden.
   c. Allow seller's to reply customers – if this is set to yes, then the seller can reply customer enquiry message.
   d. Use Product Templates - if this is set to yes, sellers can use Product Templates to make new product.
   e. Allow seller to add related product – if this is set to yes, sellers can add related products for their products
   f. Featured enabled hide edit button – if this is set yes, sellers can’t edit featured products.
   g. Allow Seller's Featured Products - if this is set yes, Seller’s featured product column hide on product list page on seller side.
   h. Allow Seller's Category Featured Products – if this is set yes, Seller’s Category Featured Products column hide on product list page on seller side.
   i. Maximum number of seller products allowed in cart – this sets maximum number of products a customer can order, for seller products.
   j. Seller review enabled - if set to yes, users can review sellers also, in addition to usual product reviews.
   k. Sellers contact mode - if set to general, then the only seller panel will visible on account page.
l. Sort by- if set to create date, then the blog will visible according to create date means in the form of descending.

m. Fields to show- if admin has check the Seller name, Store email, Store phone, Storeaddress, Social Links then information will visible on store view page.

n. Invoice/shipping generated by seller- if set to yes, then the seller can generate invoice/shipping. If this option is select NO, you can hide customer details for sellers.

o. Seller Account Terms- Admin can set information page to be shown for sellers while registration.

12. Subscription Tab: -
   a. Enable Subscription Plans- if set to yes, then the subscription plan will enable for seller after that the some field will visible then you can configure according to your need.

13. Other setting Tab
   NA

14. Development Tab
   a. Include jQuery- if set to yes, then the jQuery library from this extension will be included.

15. Now click on the ‘Save’ button on the upper right corner. This completes basic configuration.

16. Registration
   a. This tab is used for hide seller registration fields for seller while registration on the Multivendor integrated website.

17. You’ll see the ‘Multivendor’ menu above Reports menu when you enable the module as described below in Usage Instructions.
8 Clear the cache after installing extension. Cache path is different according to Opencart setup, mostly cache path is Root folder/storage/cache
Delete all folders and files inside of cache folder
Upgrade Instructions

You can uninstall the extension and install the latest version, but this results in data loss. To keep data intact, use following steps:

1. Login to Admin panel
2. On left navigation, click on Extensions->Modifications
   - Click on Multivendor extension check box
   - Click delete button in top right corner
   - Click on refresh button
4. If you are on Opencart 3.x
   a. Again, click on Extensions -> Installer and install latest zip file named similar to Multivendor-extras-3.x.ocmod.zip.
5. Go to Modification and click on refresh button
6. Remove all files from storage/cache directory if you are on Opencart 3.x

   Note: Don’t uninstall the extension using Extensions->Extension option, otherwise data will be lost.

   From the admin menu “System->Users->User Groups”, Make sure the admin user group has all privileges available related to “Purpletree”.

   Note: It is possible the new version has added some privileges which are not enabled in admin for you.
   Make sure all following privileges are available:

   - extension/module/purpletree_multivendor
   - extension/module/purpletree_sellerpanel
7. On Admin left menu, from “Upgrade Database” menu, upgrade the database tables.
   Note: For this to work, the MySQL user configured for Opencart must have all privileges available.
Context Sensitive Help

Purpletree Multivendor provides Context Sensitive help. We have added a help icon on top of all multivendor-related pages on admin and seller side. It appears in the top right corner.

Help icon points to that specific feature's knowledgebase area on our website (https://www.purpletreesoftware.com/knowledgebase). This way, Context Sensitive Help provides quick help for all features related to Multivendor.

HOW TO ENABLE/DISABLE CONTEXT SENSITIVE HELP

- Be default, Context Sensitive help is enabled so you do not need to do anything.
- To disable it, you have to make change in 2 files, i.e. <root>/admin/config.php and <root>/config.php files.
- Add following line to both the files, to disable Context Sensitive Help:

  define ('DISABLED_PTS_HELP', 1);

- With this setting, the help icon does not display on any multivendor related page.
- If you do not define this variable, then help section remains enabled.

EXAMPLES
Basic Usage Instructions

1. After installing the module through extension installer, go to Extensions>Extensions.
2. Select “module” from the dropdown list.
3. Select 'Modules'. Check for the 'Multivendor settings'. Now, Click on Green button (shown as 1 below) to install the module.
4. Click on blue EDIT button (shown as 2 above) and enter configuration parameters. Here set the status to ‘Enabled’, and enter license here.

5. Now click on the ‘Save’ button on the upper right corner.

6. After that install “Multivendor Settings” and edit.

7. Then enable the module and do the setting according to the requirement, as shown below.
### Multivendor Settings

**General**

- **Status**: Enabled

**Vendor settings**

- **Admin order status for commission calculation**: Complete
- **Status of return for refund calculation**: Reduced
- **Shipping Type**: Set Code, Shipping

**Commissions**

- **Commissions (as percent per product item)**: 0%

**Settings**

- **Commission Invoice**: Yes
- **Commissions Invoice**: 0%
- **Commissions from seller group**: No
- **Commission Invoice Header Text**: 0%

**Allow seller to message orders**: Yes

**Allow order status for seller/customer**

- **Cancelled**: Cancelled Refund
- **Closed**: Complete
- **Complete**: Delayed

**Show Dashboard Seller Panel Icons**

- **Order Overdue Messages**: Yes
- **Customer Emoies**: Yes
- **Subscription Plan Status**: Yes
- **Reviews**: Yes
- **Downloads**: Yes
- **Data Info**: Yes

**Allow customer to message orders**: Yes

**Order Approval Required**

- **Order Approval Required**: Yes
- **Product Approval Required**: Yes

**Allow category for seller**

- **Allow all categories**: Yes

**No of categories allow for a single product**

- **Multiple**: Yes

**Show Seller Login/Seller Panel Link**

- **Team In Live Chat**: Yes

**Enable Store sellers**

- **Enable Store sellers**: Yes

**Hide User Info for sellers**

- **Hide User Info for sellers**: Yes

**Hide domain wise stores**

- **Hide domain wise stores**: Yes

---

Copyright © 2009-2022 All Rights Reserved. 
Version: 3.5.6.2
10. On this page, you can enable/disable allowing product approval, seller approval, category for sellers, Seller Login / Seller Panel Link show or not in website header etc.

11. After enabling Multivendor module you see the “Multivendor” menu in left side with sub menus.

12. In “Sellers” menu you see the list of signed-up sellers.
13. In “Stores” menu you see the stores created by sellers.
14. When you edit stores, you see the tabs which show different details about that seller store like seller products, assign product to seller, seller order list, defining shipping charges, payment list, commission list and seller reviews.
15. Now, If you want to enable custom shipping (seller shipping); go to “Extensions->Extensions” and select ‘Shipping’. Here, search for ‘Multivendor Shipping’, install it and set the status ‘enable’. (You can also define sort order of shipping charges)
16. Save the setting and follow further instructions.
17. You can also add SEO URL for shop.

18. Scroll down, admin can add/edit links to social handles of the seller. These social handle links are shown on seller store page on the frontend.
19. In “store detail” tab you enter all details related to store.
20. Clicking on “Manage products” button, you see list of products assign to that store.
21. In “Add product” tab you can assign new products through checkbox, then click on save button.
• When you click on “Manage Orders” button you see the list of orders for that particular store.
• When viewing the particular order, you see all order details according to sellers. Here you see only the products related to current seller. You also see the order history of that particular order set by current seller.

22. In “Shipping charges” tab you can set the charges for shipping.
23. The “Seller commission” tab shows seller-wise commission.
24. The “Payments” button shows the list of payments done with date filter.
25. The “Manage Commissions” button shows the Order with product-wise commission you got from sellers.

26. The “Manage Reviews” button shows the list of reviews given by customers to seller. You can edit them through click on edit icon.
27. In “sellers products” menu you see the list of seller products with seller name.
28. You can approve the products by checking-on the checkbox then clicking on “Approve” button.
29. You can unassigned products by checking-on the checkbox then clicking on “Unassign” button.
30. In “Seller Orders” menu you see the list of seller orders.
31. When viewing the order detail, you see the store name with product name on the product detail page.
32. The “Seller reviews” option shows the list of seller reviews. Click on “edit” icon to approve the review.
33. The “Customer enquiries” option shows list of customer enquiries. Click on “view” icon to see the full details.
34. You can assign/unassigned and re-assign product to seller in Opencart default products menu.
35. Go to “Catalog/Products” and choose ‘edit product’ or ‘add new product’.
36. In ‘Vendor’ tab, there will be a dropdown list of sellers. Select the seller to whom you want to assign this product.

37. In “Categories Commission” menu you can set commission percentage on per category basis. You can add, edit and delete Categories Commission, click on “Add”, “edit” and “delete” buttons.

Adding Commission value for a category:

- Click on Categories input box, you can select category from drop down.
• Give the commission on the Commission input box (this is percentage of total value), then click “Add”.

You can also edit commission for a category using edit options.

38. In “Upgrade Database” menu you can upgrade your database tables, when upgrading the extension.
   • Click on Upgrade button you can upgrade your database.
Hide customers' Details from sellers

If admin wants to hide customers’ details from sellers, the new feature is there for hiding customers’ details from sellers.

This option is valid only when shipping Handled by admin is selected.

Invoice/shipping generated by seller is selected as NO.

Go to Multivendor>Settings>Seller>Invoice/shipping generated by seller No.

Select Hide Customer Details from seller.

Now, this will hide customer details in Seller Dashboard/Panel.

a. Seller Order List
b. Summary

<table>
<thead>
<tr>
<th>Order ID</th>
<th>Status</th>
<th>Admin Status</th>
<th>Commission</th>
<th>Total</th>
<th>Date Added</th>
<th>Date Modified</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>109</td>
<td>Complete</td>
<td>Complete</td>
<td>$9.00</td>
<td>$94.10</td>
<td>07/04/2022</td>
<td>07/04/2022</td>
<td></td>
</tr>
<tr>
<td>108</td>
<td>Complete</td>
<td>Complete</td>
<td>$121.10</td>
<td>$1,321.10</td>
<td>06/04/2022</td>
<td>06/04/2022</td>
<td></td>
</tr>
<tr>
<td>107</td>
<td>Complete</td>
<td>Complete</td>
<td>$29.10</td>
<td>$384.12</td>
<td>06/04/2022</td>
<td>06/04/2022</td>
<td></td>
</tr>
</tbody>
</table>

c. Seller Invoice
d. Shipping Print

Dispatch Note #109

Now, Admin can hide the seller registration fields for seller registration form at the website.
For this GotoMultivendor>Registration Tab>Select Fields to hide.
Not mandatory/Required fields cannot be hidden.
Now see at registration form following fields are hidden.
Now you can see selected fields are hidden at seller registration form.
Seller Account Terms

When a seller registers on the Opencart Multi-Vendor Website, there is a term/policy page for the seller to go through it and accept, it is also when a customer registers on the website.

Catalog>Information

There is an option provided for the admin to show a particular information page on Seller Account Terms while registering in Multivendor admin itself.

Go to Multivendor>Admin>Seller>Account Terms
By Default, if the admin has not selected any particular information page here, it will show the same page as showing for customers while registration.

If Admin selects the particular information page for example Seller Terms and Conditions it will show that page on the seller registration form.

See the registration form now

You are seeing “Seller Terms and Conditions” on seller registration form now.
Frontend side

1. If “Purpletree Multivendor” extension is enabled, then user can view Seller Login link on header. Click on that link to register as seller. If Customer is already logged then that link would redirect to Seller register page, else Seller Login page will open.

2. Enter the store information such as store name, email address etc.

3. In the final step, fill the seller's bank details. Then click to submit button.
4. After registering as a seller, you see Seller Panel link on header and seller dashboard if admin approval not required.
5. If admin approval required then request is send to admin for approval, seller will reach on seller approval page.

6. In “Dashboard” seller can reach all seller pages using Left menu or from icons and links on Dashboard page.
7. If the customer wants to become a seller, then, click to seller login from the header of website as shown below.
8. In the case, if you are not able to see “Seller Login” as well as “Browse Sellers” on the header of website, then you need to follow these steps. We have supported most of the themes and are adding the new theme compatibility in our extension in each update.

**Fortwig Template**

- First you need to go into your theme files “upload/catalog/view/theme/yourtheme/template/common/header.twig

- Then paste the given code.

```twig
{% if (module_purpletree_multivendor_status) and (module_purpletree_multivendor_seller_login) %}
  {% if sellerlogged %}
    <li style="float:left;list-style:none;"><span><a class="headadd" href="{{ seller_panel_link }}"><i class="fas fa-user" aria-hidden="true"></i><span class="hidden-xs">{{ text_seller_panel }}</span></a></span>
  {% if not totalnotification==0 %}<span style="background: #5bad26;color: #fff;padding: 2px 6px;border-radius: 50%;font-size: 11px;position: relative;font-weight: 600;top: -7px;" class="pts-counting-seller-pannel">{{ totalnotification }}</span>{% endif %}</li>
  {% else %}
    <li style="float:left;list-style:none;"><span><a class="headadd" id="pts-login-seller" href="{{ seller_register_link }}"><i class="fas fa-user" aria-hidden="true"></i><span class="hidden-xs"> {{ text_seller_register }}</span></a></span>
  {% endif %}
{% endif %}
```
{% endif %}
{% if module_purpletree_multivendor_browse_sellers %}
<li style="float:left;list-style:none;paddingleft:10px;"><span><a class="headadd" href="{{ browse_seller_link }}"><i
class="fafa-users" aria-hidden="true"></i><span class="hidden-xs" >{{
text_browse_sellers }}</span></a></span></li>
{% endif %}

1. Then Install the theme into your Opencart.

For .tpl Template
•

First you need to go into your theme files
“upload/catalog/view/theme/yourtheme/template/common/header.tpl

•

Then paste the given Code.

<?php if((isset($purpletree_multivendor_status)
&&($purpletree_multivendor_status == 1) )&&
(isset($purpletree_multivendor_seller_login)&&
($purpletree_multivendor_seller_login == 1) )) { ?>
<?php

if (!isset($sellerlogged)) { ?>

<li><span><a href="<?php echo
$seller_register_link; ?>"><i class="fafa-user fasfa user-o"
aria-hidden="true"></i><span class="hidden-xs"><?php echo
$text_seller_register; ?></span></a></span></li>
<?php }else{ ?>
<li><span><a href="<?php echo
$seller_panel_link; ?>" class=""><i class="fafa-user fasfa
user-o" aria-hidden="true"></i><span class="hidden-xs"><?php
echo $text_seller_panel; ?></span><?php if
(!$totalnotification==0) { ?>
<span style="background: #5bad26;color:
#fff;padding: 3px 6px;border-radius: 50%;font-size:
11px;position: relative;font-weight: 600;top: -7px;"
class="pts-counting-seller-pannel"><?php echo
$totalnotification; ?></span>
<?php } ?></a>
</span></li>

Page | 65
www.purpletreesoftware.com


<?php }} ?>

<?php if (isset($purpletree_multivendor_browse_sellers) && $purpletree_multivendor_browse_sellers == 1) { ?>

<li><span><a href="<?php echo $browse_seller_link; ?>"><i class="fafa-users" aria-hidden="true"></i><span class="hidden-xs"><?php echo $text_browse_sellers; ?></span></a></span></li>

<?php } ?>

2. Then Install the theme into your Opencart.

9. Customer can see a login page, if customer is already approved seller. If not, then click to “Register Here” link.

![Seller Login](image)

10. In the first step fill all fields and all the fields are required here.
11. In 2nd step, enter your store details. Only “Store Name” is required here.
12. In “Facebook link”, “Twitter Links”, “Instagram links”, “Pinterest links” seller can add their accounts links by providing the link in input boxes.

13. Seller can add own external website link by providing the link in “Website Links” input box.

14. If Allow Tawk.to Live Chat is enabled in Multivendor setting then “Allow Tawk.to Live Chat” field and Tawk.to Widget Code field visible this page. If seller wants to use Live Chat then set Yes for Allow Tawk.to Live Chat and enter Tawk.to Widget code.

15. The links only appears which are provided by seller, on the store view page.

16. In the final step fill the seller bank details and all other fields, and then click to submit button,
17. Customer will be registered as seller, if customer is approved seller, customer will be reach to seller dashboard page, if approval is required then customer have to wait for admin approval.
18. If seller wants login, click to “Seller Login” from the top of store.

19. Seller can see the login page. Enter registered “Email” and “Password” then click to login after that will reachon seller dashboard Page.
20. In “Dashboard” menu, seller can reach all seller pages using Left menu.
21. In “Summary” menu Seller can review their sales, commissions, and payments coming from Admin in a comprehensive dashboard.

22. In “Seller Profile” menu you update the sellers’ basic detail like first name, last name, email etc.
23. In “Store Information” menu you update the store information details.

24. You can set for the store as shown below. Note: Opencart’s SEO options must be enabled for this URL to work.
25. In “Facebook link”, “Twitter Links”, “Instagram links”, “Pinterest links” and Whatsapp number sellers can links to their social accounts.
26. In the “Website Link” seller can add the website by providing the link.
27. The links only appear which are provided by seller on store view page.
28. Under Catalog menu there is sub menu “Manage Products” option, sellers see their product list with status - approved or unapproved. Sellers can add new products, edit and delete them.

29. Seller can also make copy/clone of products; select the product and click on 'copy' icon.

30. Seller can also disable and enable all products if “Product approval required” set “no” in Multivendor setting.

Seller Vacation mode

In Multivendor the seller or admin can enable the vacation mode by which seller products, seller template product etc. will not appear on the website.

- To enable seller vacation from admin, go to Admin >Multivendor > Stores >Edit any store.

- Now, go to Vacation Mode tab then select “Yes” from vacation mode dropdown to enable the seller vacation mode.

- Admin can add store opening and closing time: Click input box then time picker is opened. Set the time using time picker. During the selected time interval, the shop will close, means all the products would remain disabled.

- Admin can add Scheduled Holiday for the shop. Click on input box then date picker is opened. Set the date using date picker. On the Holiday, the shop will show as closed and all the products would be disabled. Click on add holiday button to add more Holidays.
After selecting the “Yes” then click blue save button. Now, all the products are disabled of the seller whose vacation mode is enabled. Vacation products are shown by Pink background, in products list.
- On seller side to enabled or disable the seller vacation mode go to Seller Panel > Click to Store Information Option.

- Scroll down below then seller can find the Vacation Mode option dropdown then seller can choose the enable or disable.

- Admin can add store opening and closing time: Click input box then time picker is opened. Set the time using time picker. During the selected time interval, the shop will closed, means all the products would remain disabled.

- Admin can add Scheduled Holiday for the shop. Click on input box then date picker is opened. Set the date using date picker. On the Holiday, the shop will show as closed and all the products would be disabled. Click on add holiday button to add more Holidays.
What happens after enabling the seller vacation mode?

- Seller profile is still visible, but not the products.
- Seller blog will not be visible.
- Seller is not visible in the seller featured module.
- Customer would not be able to contact with seller.
- Seller product shall be disabled when seller turns on the vacation mode. But when seller turns vacation mode off, all the products disabled due to vacation are again enabled.
- The products which were disabled before turning on the vacation mode will remain disabled whatever you set for the vacation mode.
- Seller template products are not visible in seller price module on product detail page.
- Seller shall not be visible in store featured module
- When seller adds product from bulk product the product will be added but as disabled.

When seller disables the vacation mode, then all of above works as usual.
Sellers can add or edit products and enter all required details for products for multiple languages. The products which have disabled status due to vacation will appear with Pink background.
Quick Edit Seller product
Seller can edit product information like Product name, Price, Quantity, Product option etc. by using QuickEdit button.

- Click on Quick Edit button then Quick Edit popup opens. Update information and click save button.
**Product view**

- **Goto - Multivendor-> Setting> Seller Tab**

- Under Products View option, admin can set options to show grid view and list view on seller product listing page under seller panel.

- Seller can change product list view using List and Grid view button.

**Smart product form**

- **Goto - Multivendor-> Setting> Seller Tab.**

- Enable Use Smart Product Form – Select “Yes” to Enable the Use Smart Product Form, if set to “No”. Everything will work fine with normal product form any conditions.

- You add or edit product and enter all required details which is mandatory for products for multiple languages.
• Smart Product Form has two tabs only - General and Data. In General tab we have product name, product description, product tag, category, and subcategory and image sections. Data tab is for settings for the product.

![Smart Product Form](image)

31. Seller product form or Seller smart product form support Product image Manager Open cart extension only for Multivendor2x.

![Seller Products](image)

32. Under Sales ->Orders menu, sellers see their order list with order details.
33. In “Payments” sub menu, sellers see the list of payments received from admin.

34. Under Sales menu, there “Commission” sub menu, sellers see commission given to admin, product-wise.
35. Under Sales menu, there is “Commission Invoice” sub menu, sellers see commission invoice given to admin, product-wise

36. In “Shipping rates” menu sellers can set shipping charge for their products.

37. In “Bulk Product Upload” menu sellers can create multiple product by using excel sheet.
38. If seller wants to remove self as seller, this can be done from “remove as seller” menu.
39. In “My Reviews” sellers see the list of reviews given by customers.

40. In “Customer enquiries” sellers see the list of enquiries posted by customers.
41. Under Catalog there is “Downloads “sub menu, Seller can create downloadable product.

42. In “Blog” Seller can create seller Blog.
43. In “Blog Comments” sellers see the list of seller blog comments given by customers.

44. If seller is assigned to product, then seller name is displayed on product details page.
45. Customers can contact sellers through product detail page or seller store page where “Contact seller” link is available, clicking on that link opens an enquiry form.

46. Users can see list of sellers on Opencart front, clicking on “Browse sellers” option in header:
Working with Advanced Shipping Module

Configuring Multivendor Advanced Shipping

- Multivendor Shipping must be installed to use advanced shipping.
- Go to Admin Panel > Extensions > Extensions > Select Shipping from Dropdown.
- Install Multivendor Shipping.
- Now click on Edit button.

- Enable the shipping.
- Admin can assign Shipping Type to be applied to admin products which are not assigned to seller.
• Shipping Type
  o Product-wise: In this type shipping rate will be applied on order per product means if 3 admin products are added in cart, then shipping rate multiple by 3 will be applied to cart.
  o Order-wise: In this type shipping rate will be applied per Order based if 3 admin products are added in cart, then single shipping rate will be applied to cart.

• Shipping Charge Type
  o Product Base Shipping: This is a Shipping type base on the product shipping charge, shipping charge define during product creation. Product Shipping has first priority. If the product shipping charge does not define then other shipping methods check during checkout.
  o Flat Rate Shipping: This is traditional Shipping method, means shipping charge which is chosen, will be applied to cart according to shipping Type defined.
  o Advanced Shipping: This shipping charge will calculate from shipping rates defined for each non seller products. If No shipping charge is found even for 1 or more products in cart, then customer will not be able to checkout using Multivendor Shipping Method. Before using this shipping method make sure all shipping rates are defined as explained in next section of this Document.
  o Flexible Shipping: In this, when customer try to checkout Non Seller products, first for each product/order it will look for shipping charge from Shipping Rates. If not found then Flat Shipping charge will be applied.

• Shipping Charge: This Shipping charge will be used for Flat rate Shipping and Flexible shipping for Non Seller Products.
Add/Edit shipping rate for product from Admin Panel
Login as an admin and go to "Navigation" menu select catalog and click on it. After that select product option. You will reach on products list page. Here you can add new product and edit product. If you can click on add and edit button you will reach on product form page. When you reached on product form page then you can select data tab and find shipping charge input box. Enter shipping charge amount here and click on save button.
Add/Edit shipping rate for product from Seller Panel
Login as a seller in seller panel and go to catalog in left menu and click on it. After that select products option. You will reach on products list page. Here you can add new product and edit product. If you can click on add and edit button you will reach on product form page. When you reached on product form page then you can select data tab and find shipping charge input box. Enter shipping charge amount here and click on save button.
In smart Product form

Defining Shipping Rates from Admin Panel

- Login to admin Panel > Multivendor > Shipping Rates.
• From here admin can view list of shipping rates which will be applied to order.
• Admin can also go to global settings of Purpletree shipping from here by click **Manage Shipping Options** Link on top.
• Shipping Rates can only be added and deleted; Edit option is not there to edit any shipping rate.

**Note:** Purpletree Multivendor and Multivendor Shipping must be enabled for shipping rates to apply.

• Click on Add new from top right.
• Admin can assign shipping Rate to any seller.
• Select Seller name from dropdown in 1st column.
• First option in Seller name is N/A, which means this shipping rate will be applied to admin products.
• Select Country from dropdown list.
• Enter **Zip From** and **Zip To** Range.
• If Zip code is not numeric then **Zip From** and **Zip To** must be same to enable this shipping rate.
• Enter **Price** to be applied for this condition. This is the shipping rate.
• Enter **Weight From** and **Weight To** Range.
• **Weight To** must be greater than **Weight from**, but both can be set to 0 if not known.
Defining Shipping Rates from Seller Panel

- Login to Seller Panel >Shipping Rates.
- From here seller can view list of shipping rates which will be applied to order.
- Shipping Rates can only be added and deleted; Edit option is not there to edit any shipping rate.

![Shipping Rates](image)

**Note:** Purpletree Multivendor and Multivendor Shipping must be enabled for shipping rates to apply.

- Click on Add new from top right.
- Select Country from dropdown list.
- Enter **Zip From** and **Zip To** Range. This is Optional field now.
- If Zip code is not numeric then **Zip From** and **Zip To** must be same to enable this shipping rate.
- Enter **Price** to be applied for this condition. This is the shipping rate.
- Enter **Weight From** and **Weight To** Range.
- **Weight To** must be greater than **Weight from**, but both can be set to 0 if not known.

Configuring Advanced Shipping for seller products via Admin Panel
Go to Admin > Multivendor > Manage Stores > Edit Store > Shipping
From here select Shipping Type to be applied for this seller products, Seller can also change values over here from seller panel.

**Shipping Type**
- **Product-wise:** In this type, shipping rate for all ordered products will be fetched and added to the cart, to build final shipping rate.
- **Order-wise:** In this type, shipping rate will be applied on whole Order, based on total weight of the order.

**Shipping Charge Type**
- **Flat Rate Shipping:** This is fixed shipping charge for all products.
- **Advanced Shipping:** This will take all shipping rates defined into account, which are defined with zip code, weight etc.
- **Flexible Shipping:** In this, when customer try to checkout Seller products, first for each product/order it will look for shipping charge from Shipping Rates (based on zip, weight etc.). If no rate found then **Flat Shipping charge** will be applied.

**Shipping Charge:** This Shipping charge will be used as the flat fee for Flat rate Shipping and Flexible shipping for Seller Products.

Configuring Advanced Shipping for seller products via Seller Panel

- Login to seller Panel.
- Go to Store Information on seller Panel.
- In Last there are three options to configure Advanced Shipping.
- Select Shipping options as desired as explained above for admin panel and Save the Store.

Shipping Rates Bulk import via Admin Panel

- Shipping Rates data can be Exported and then Imported with Excel Sheet.
- In Admin Panel go to >Multivendor > Shipping Rates >**Bulk Upload Button**
• **Export Data** - Select Seller from Dropdown and click on Export to export excel sheet with Shipping Rates. Select “--None--” option to export Shipping rates of admin Products.

• **Import Data** – Use the Exported sheet or create new Excel sheet with following fields and select seller to upload shipping rates. Select “--None--” option to import Sipping rates of admin Products. All Fields in the sheet are required except id.
  
  o **id** – Unique id of exported sheet. Leave blank to create new row, to edit the previous entry keep the id and change data as required. Entering Invalid id will neither edit any data nor create any new row.
  
  o **shipping_county** – Enter Country Name, Valid country needs to be entered. This filed is required and if country is not found data will not be insert or update this row.
  
  o **zipcode_from** – Optional fields, Enter Zip code, it may be numeric or alphanumerick. If Zip code is not numeric then Zipcode From and ZipcodeTo must be same to enable this shipping rate.
  
  o **zipcode_to** – Optional fields, Enter Zipcode, it may be numeric or alphanumerick. If Zipcode is not numeric then Zipcode From and ZipcodeTo must be same to enable this shipping rate.
  
  o **shipping_price** – Required field, Enter valid price in number or decimal. Invalid entry will not insert or update this row
  
  o **weight_from** - Required field, Enter valid weight in number or decimal. Invalid entry will not insert or update this row.
  
  o **weight_to** - Required field, Enter valid weight in number or decimal. Weight to must be always greater than weight from. Invalid entry will not insert or update this row.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>32</td>
<td>India</td>
<td>201200</td>
<td>210300</td>
<td>10</td>
<td>0</td>
<td>100</td>
</tr>
<tr>
<td>28</td>
<td>India</td>
<td>201301</td>
<td>201300</td>
<td>11</td>
<td>0</td>
<td>100</td>
</tr>
<tr>
<td>29</td>
<td>Armenia</td>
<td>201200</td>
<td>30000</td>
<td>11</td>
<td>0</td>
<td>100</td>
</tr>
<tr>
<td>31</td>
<td>India</td>
<td>fdtsky</td>
<td>fdfsfd</td>
<td>77</td>
<td>11</td>
<td>111</td>
</tr>
</tbody>
</table>
Shipping Rates Bulk import via Seller Panel

- Shipping Rates data can be Exported and then Imported with Excel Sheet.
- In Seller Panel go to > Shipping Rates > **Bulk Upload Button**
- **Export Data** - Click on Export to export excel sheet with Shipping Rates.
- **Import Data** – Use the Exported sheet or create new Excel sheet with following.
- All Fields in the sheet are required except id.
  - **id** – Unique id of exported sheet. Leave blank to create new row, to edit the previous entry keep the id and change data as required. Entering Invalid id will neither edit any data nor create any new row.
  - **shipping_county** – Enter Country Name, Valid country needs to be entered. This filed is required and if country is not found data will not be insert or update this row.
  - **zipcode_from** – Optional fields, Enter Zipcode, it may be numeric or alphanumeric. If Zipcode is not numeric then Zipcode From and ZipcodeTo must be same to enable this shipping rate.
  - **zipcode_to** - Optional fields, Enter Zipcode, it may be numeric or alphanumeric. If Zipcode is not numeric then Zipcode From and ZipcodeTo must be same to enable this shipping rate.
  - **shipping_price** – Required field, Enter valid price in number or decimal. Invalid entry will not insert or update this row.
  - **weight_from** - Required field, Enter valid weight in number or decimal. Invalid entry will not insert or update this row.
  - **weight_to** - Required field, Enter valid weight in number or decimal. Weight to must be always greater than weight from. Invalid entry will not insert or update this row.
Purploetree Geo Zone Shipping

In the Purploetree geozone shipping admin and seller can able to create their own shipping rates for the multiple zones or admin can assign the shipping zones to sellers.

Admin have a choice to choose the type of shipping he/she wants to apply for sellers.

Enable Purploetree shipping module

- Go to Admin > Extension > Extension > Select “Shipping” from dropdown > Multivendor Shipping. Then click to green color install button after that click to blue color edit button.
• Now Choose "Enabled" from the status dropdown then click to blue color save button.
We have provided the choice between zip code shipping and geo zone shipping. Admin can select only one at a time. If admin has selected the zip code shipping, then the shipping works based on zip code. If geo zone is selected, then shipping will work based on zones as like described below.

Select the shipping type which admin wants to use. Go to Multivendor > General Tab > Shipping Type > Geo Zone Shipping then click to save blue color button.

To create geo zone shipping, admin should go to Shipping Rates > Click to Add Button.
Create geo zone shipping by admin

- Select the seller store name from auto complete dropdown, Geo Zone Name, Description and ill the Shipping price. After that add country zones whichever the seller is charging during ordering from the customer.

- If N/A is selected from dropdown that means the shipping charge will be applicable on the admin products.

- Click to blue color save button.
Admin can add, delete and the third option 'Manage Shipping Options' is for admin product how admin wants to set their shipping price.

Configuring Advanced Shipping for seller products via Admin Panel
• Go to Admin > Multivendor > Stores > Edit Store > Shipping
• From here select Shipping Type to be applied for this seller products, Seller can also change values over here from seller panel.

**Shipping Type**
- **Product-wise:** In this type, shipping rate for all ordered products will be fetched and added to the cart, to build final shipping rate.
- **Order-wise:** In this type, shipping rate will be applied on whole Order.

**Shipping Charge Type**
- **Flat Rate Shipping:** This is fixed shipping charge for all products.
- **Advanced Shipping:** This will take all shipping rates defined into account, which are defined with country, zone etc.
- **Flexible Shipping:** In this, when customer try to checkout Seller products, first for each product/order it will look for shipping charge from Shipping Rates (based on country, zone). If no rate found then **Flat Shipping charge** will be applied.

**Shipping Charge:** This Shipping charge will be used as the flat fee for Flat rate Shipping and Flexible shipping for Seller Products.

Configuring Advanced Shipping for seller products via Seller Panel
- Login to seller Panel.
- Go to Store Information on seller Panel.
- In Last there are three options to configure Advanced Shipping.
- Select Shipping options as desired as explained above for admin panel and Save the Store.
Create geo zone shipping by Seller

- Go to Seller Options > Click to ‘Shipping Rates’ menu.

- Click to add button.
- Fill the Name, Description and the shipping price.
- After that add the shipping country and zones then click to save button.
- Seller can Edit and delete the geo zone shipping.
- When the customer is ordering the product of the seller or the seller, its calculation will only be applied according to as defined in the geo zone shipping rates.
Product Bulk Upload

Admin and seller both can Export and Import Products data,
Product Bulk Upload from Admin Panel
• Login to admin Panel > Multivendor > Bulk product upload.
• On top it shows **Maximum time allowed for upload** and **Maximum file size allowed for upload**. Make sure values are high enough configured on your server for bulk data to import.

**Export Data** - Select Seller from dropdown, Select Language from dropdown and click on Export button to export specific product of any seller. Select "—None—" seller to export product which are not assigned to any seller.

**Import New Products Data** – Use downloaded template data sheet to import new products. Click on import button. Admin will have to use ‘Import new product’ section to import new products.
  - Select Seller from List. Select None for admin products.
  - Select Language from list.
  - If you want to add new product data then the product id will work as a reference id.
  - As Explained below in Excel sheet there are 13 tabs. In **General and Data** Tab if any error occurs to insert or update data. No data row will be inserted or updated for that particular product id in any of the tabs afterwards.

**Updating Existing Products Data** – Use Exported data sheet to update existing products or to edit any products. Exported Data sheet will have 13 tabs for all data.
  - Select Seller from List. Select None for admin products.
  - Select Language from list.
  - If you want to update data and not sure if it already exits simply use exported sheet format and update data accordingly. Click on update button.
  - As Explained below in Excel sheet there are 13 tabs. In **General and Data** Tab if any error occurs to update data. No data row will be inserted or updated for that particular product id in any of the tabs afterwards.
• You can also see the bulk product data status in Bulk Product Import/Update Status text area.

-- Bulk Product Import/Update Status --

Product Bulk Upload from Seller Panel

• Login to Seller panel.
• Go to Bulk Product Upload.
• On top it shows Maximum time allowed for upload and Maximum file size allowed for upload. Make sure values are high enough configured on your server for bulk data to import.
• Export Data - Select Language from dropdown and click on Export button.
• Import New Products Data – Use downloaded template data sheet to import new products. Click on import button. Seller will have to use ‘Import new product’ section to import new products.
  o Select Language from list.
If you want to add new product data then the product id will work as a reference id.

As explained below in Excel sheet there are 13 tabs. In **General and Data** Tab if any error occurs to insert or update data. No data row will be inserted or updated for that particular product id in any of the tabs afterwards.

- **Updating Existing Products Data** – Use Exported data sheet to update existing products or to edit any products. Exported Data sheet will have 13 tabs for all data.
  - Select Language from list.
  - If you want to update data and not sure if it already exists, simply use exported sheet format and update data accordingly. Click on update button.
  - As explained below in Excel sheet there are 13 tabs. In **General, and Data** Tab if any error occurs to update data. No data row will be inserted or updated for that particular product id in any of the tabs afterwards.

- You can also see the bulk product data status in Bulk Product Import/Update Status text area.
Export/Import Excel Sheet Data – Excel Sheet format and tabs data. There are 13 tabs. In General and Data Tab if any error occurs to insert or update data. No data row will be inserted or updated for that particular product id in any of the tabs afterwards.

- **General** – The data in this tab is to be entered same as entered in General Tab of add/edit product. If any validation failed for any particular product id in this tab, no data will be inserted/updated for any of the tabs for that particular product id.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>product_id</td>
<td>name</td>
<td>description</td>
<td>tag</td>
<td>meta_title</td>
<td>meta_description</td>
<td>meta_keyword</td>
<td>is_approved</td>
</tr>
<tr>
<td>2</td>
<td>28</td>
<td>HTC Touch HD</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>3</td>
<td>29</td>
<td>Palm Treo Pro</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>4</td>
<td>30</td>
<td>Canon Easy</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>5</td>
<td>31</td>
<td>Nikon D300</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>6</td>
<td>32</td>
<td>iPod Touch</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>7</td>
<td>33</td>
<td>Samsung SyncMaster 941BW</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No</td>
</tr>
</tbody>
</table>

- **product_id** – This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id next to last product id given in Export data sheet.
- **name** – Enter valid alphanumeric name. Required filed
- **description** – Enter Description, you can use html tags for this.
- **tag** - Enter alphanumeric tags.
- **meta_title** - Enter alphanumeric Meta title.
- **meta_description** - Enter alphanumeric Meta description.
- **meta_keyword** - Enter alphanumeric Meta key.
- **is_approved** – If seller product, Set Yes or No to approve it as seller product or not. (This filed will only come on admin side). On Seller side this value comes from as configured in Multivendor settings for Product Approval Required or not.

- **Data** - The data in this tab is to be entered same as entered in Data Tab of add/edit product. If any validation failed for any particular product id in this tab, no data will be inserted/updated for any of the tabs for that particular product id.

| A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S |
| product_id | model | sku | upc | isbn13 | isbn10 | isbn13 | isbn10 | location | quantity | stock_states | image | manufacturer | shipping | price | price_extra_type | price_extra | points | tax_class |
| 1 | Model A | A123 | 12345 | 0987654321 | 1234567890 | A123 | 1234567890 | Location 1 | 5 | Out Of Stock | HTC | Yes | 5 | 0 | 5 |
| 2 | Model B | B123 | 12345 | 0987654321 | 1234567890 | B123 | 1234567890 | Location 2 | 5 | Out Of Stock | HTC | Yes | 5 | 0 | 5 |
| 3 | Model C | C123 | 12345 | 0987654321 | 1234567890 | C123 | 1234567890 | Location 3 | 5 | Out Of Stock | HTC | Yes | 5 | 0 | 5 |

* Product approval required: Yes
- **product_id** - This is a required field. It must be numeric. To edit any product data, enter a valid product ID. To insert a new product, use any product ID series and maintain that series between all the tabs for a given product. During product addition, this product ID series will be replaced by an actual OpenCart product ID.
- **model** - A required field. Enter a valid model name.
- **sku, upc, ean, isbn, mpn, location** - Enter valid data in all these fields.
- **quantity** - Enter valid numeric quantity available for the product.
- **stock_status** - Enter a status of stock. Default values are:
  - 2-3 Days
  - In Stock
  - Out Of Stock
  - Pre-Order
- **image** - Enter an image path with a full HTTP address. Our code will download the image and place it.
- **manufacturer** - Enter a valid manufacturer name.
- **shipping** - Enter "Yes" or "No" if the product is available for shipping or not.
- **price** - Enter a valid numeric price.
- **points** - This field is for Reward Points. Enter the total points for this product in this field.
- **tax_class** - Enter a valid tax class as shown in catalog products. Leave it blank for none or enter a tax class name. Default tax classes are "Taxable Goods" and "Downloadable Products".
- **date_available** - Enter a valid date in yyyy-mm-dd format. For example, 2018-01-01.
- **weight** - Enter a valid numeric weight.
- **weight_class** - Enter a valid class as shown in catalog products. Default weight classes are:
  - Kilogram
  - Gram
  - Pound
  - Ounce
- **length, width, height** - Enter valid numeric values.
- **length_class** - Enter valid length classes. Default classes are:
  - Centimeter
  - Millimeter
  - Inch
- **subtract** - Enter "Yes" or "No" for subtracting stock value.
- **minimum, sort_order** - Enter valid numeric values.
• **status** – Enter Status as "Enabled" or "Disabled" for product.
• **shipping charge** - Enter valid numeric shipping charge.

  - **Links** – Links data tab content.

<table>
<thead>
<tr>
<th>product_id</th>
<th>download</th>
<th>category</th>
<th>filter</th>
<th>related</th>
<th>store</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>pts Product</td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>28</td>
<td>Desktops, Phones &amp; PDAs</td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>29</td>
<td>Desktops, Phones &amp; PDAs</td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>30</td>
<td>Desktops, Cameras</td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>31</td>
<td>Cameras</td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>32</td>
<td>MP3 Players</td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
<tr>
<td>33</td>
<td>Desktops, Components &gt; Monitors</td>
<td></td>
<td></td>
<td></td>
<td>Default</td>
</tr>
</tbody>
</table>

  - **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
  - **download** – Enter download item name. If more than 1 use Comma separate for multiple values. If not found it will go blank.
  - **category** – Enter Category Name with parent using “>” as in admin. Use comma separated for multiple values. If not found it will go blank.
  - **filter** – Enter valid filter names. Use comma separated for multiple values. If not found it will go blank.
  - **related** – Enter Related product names. Use comma separated for multiple values. If not found it will go blank.
  - **store** – Enter store for which you want to enter all values of row. Use “Default” store or any other custom store.

  - **Attribute** – Attribute data tab content.

<table>
<thead>
<tr>
<th>product_id</th>
<th>attribute</th>
<th>text</th>
</tr>
</thead>
<tbody>
<tr>
<td>42</td>
<td>Clockspeed</td>
<td>100mhz</td>
</tr>
<tr>
<td>43</td>
<td>test 1</td>
<td>8gb</td>
</tr>
<tr>
<td>43</td>
<td>No. of Cores</td>
<td>1</td>
</tr>
<tr>
<td>47</td>
<td>No. of Cores</td>
<td>4</td>
</tr>
<tr>
<td>47</td>
<td>test 1</td>
<td>16GB</td>
</tr>
<tr>
<td>1000</td>
<td>No. of Cores</td>
<td>33GB</td>
</tr>
<tr>
<td>1001</td>
<td>Description</td>
<td>3GB</td>
</tr>
<tr>
<td>1002</td>
<td>test 2</td>
<td>4GB</td>
</tr>
</tbody>
</table>

  - **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
  - **attribute** – Enter Valid attribute name. If not found it will go blank.
- **text** – Enter Value of attribute.
  - **Recurring** – Recurring data tab content.

<table>
<thead>
<tr>
<th>product_id</th>
<th>recurring</th>
<th>customer_group</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1001</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1001</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **recurring** – Enter Valid Recurring Profile name. If not found it will go blank.
- **customer_group** – Enter Valid Customer Group Name. If not found it will go blank.

- **Discount** – Discount data tab content.

<table>
<thead>
<tr>
<th>product_discount_id</th>
<th>product_id</th>
<th>customer_group</th>
<th>quantity</th>
<th>priority</th>
<th>price</th>
<th>date_start</th>
<th>date_end</th>
</tr>
</thead>
<tbody>
<tr>
<td>452</td>
<td>42</td>
<td>Default</td>
<td>30</td>
<td>1</td>
<td>66</td>
<td>0000-00-00</td>
<td>0000-00-00</td>
</tr>
<tr>
<td>451</td>
<td>42</td>
<td>Default</td>
<td>20</td>
<td>1</td>
<td>77</td>
<td>0000-00-00</td>
<td>0000-00-00</td>
</tr>
<tr>
<td>450</td>
<td>42</td>
<td>Default</td>
<td>10</td>
<td>1</td>
<td>88</td>
<td>0000-00-00</td>
<td>0000-00-00</td>
</tr>
<tr>
<td>463</td>
<td>1000</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
<tr>
<td>456</td>
<td>1001</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
<tr>
<td>514</td>
<td>1002</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
<tr>
<td>522</td>
<td>1002</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
<tr>
<td>521</td>
<td>1002</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
<tr>
<td>520</td>
<td>1002</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
<tr>
<td>519</td>
<td>1002</td>
<td></td>
<td>4</td>
<td>9</td>
<td>10</td>
<td>2018-02-05</td>
<td>2018-05-24</td>
</tr>
</tbody>
</table>

- **product_discount_id** – This is numeric filed. If you want to update any existing discount use exported data id else leave it blank to add new row.
- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **customer_group** – Enter Valid Customer Group Name. If not found it will go blank.
- **quantity** – Enter valid numeric quantity for this discounted item.
- **priority** – Enter valid numeric priority value.
- **price** – Enter valid numeric price for this discounted row of product.
- **date_started** – Started date of this discount in yyyy/mm/dd format.
- **date_end** – Started date of this discount in yyyy/mm/dd format.

- **Special** – Special data tab content.
- **product_special_id** – This is numeric filed. If you want to update any existing special item use exported data id else leave it blank to add new row.
- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **customer_group** – Enter Valid Customer Group Name. If not found it will go blank.
- **quantity** – Enter valid numeric quantity for this special item.
- **priority** – Enter valid numeric priority value.
- **price** – Enter valid numeric price for this special row of product.
- **date_started** – Started date of this special price in yyyy/mm/dd format.
- **date_end** – Started date of this special price in yyyy/mm/dd format.
- **Image** – Image data tab content.

<table>
<thead>
<tr>
<th>product_image_id</th>
<th>product_id</th>
<th>image</th>
<th>sort_order</th>
</tr>
</thead>
<tbody>
<tr>
<td>2500</td>
<td>28</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>2499</td>
<td>28</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>1987</td>
<td>29</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>1988</td>
<td>29</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>2487</td>
<td>30</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>2486</td>
<td>30</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>2497</td>
<td>31</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>2498</td>
<td>31</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
<tr>
<td>2496</td>
<td>31</td>
<td><a href="http://opencart3020.purpletreedemo.com/image/catalog/">http://opencart3020.purpletreedemo.com/image/catalog/</a></td>
<td>0</td>
</tr>
</tbody>
</table>

- **product_image_id** – This is numeric filed. If you want to update any existing image item use exported data id else leave it blank to add new row.
- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **image** – Enter Valid image URL using http or https.
- **sort_order** – Enter valid numeric sort order value.
- **Reward points** – Reward Points data tab content.
- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.

- **customer_group** – Enter Valid Customer GroupName. If not found it will go blank.

- **points** – Enter valid numeric points value.
  - SEO – SEO data tab content.

- **store** (This field is for only Opencart Version 3.x) – Enter Valid StoreName. If not found it will go blank. Use “Default” Store or any other custom store.

- **keyword** – Enter Valid keyword for SEOURL of product.
  - Design – Design data tab content.
- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **store** – Enter Valid StoreName. If not found it will go blank. Use “Default” Store or any other custom store.
- **layout** – Enter Valid layout name as in admin catalog product.
  - **ProductOption** – Options define tab data.

<table>
<thead>
<tr>
<th>product_id</th>
<th>type</th>
<th>name</th>
<th>value</th>
<th>required</th>
</tr>
</thead>
<tbody>
<tr>
<td>30</td>
<td>select</td>
<td>Select</td>
<td></td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>select</td>
<td>Select</td>
<td></td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>select</td>
<td>Size</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>42</td>
<td>datetime</td>
<td>Date &amp; Time</td>
<td>2011-02-20 22:25</td>
<td>No</td>
</tr>
<tr>
<td>42</td>
<td>date</td>
<td>Date</td>
<td>2011-02-20</td>
<td>No</td>
</tr>
<tr>
<td>42</td>
<td>text</td>
<td>Text</td>
<td>test</td>
<td>No</td>
</tr>
<tr>
<td>42</td>
<td>radio</td>
<td>Radio</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **type** – Enter Valid type of option you want to create. If not found it will go blank.
- **name** – Valid Name of option.
- **value** - value of option if not radio, checkbox or select.
- **required** – Set “Yes” or “No” for this option. If not set “No” will go for this option.
  - **ProductOptionValue** – Options values for option tab data.

<table>
<thead>
<tr>
<th>product_id</th>
<th>option</th>
<th>option_value</th>
<th>quantity</th>
<th>subtract</th>
<th>price</th>
<th>price_prefix</th>
<th>points</th>
<th>points_prefix</th>
<th>weight</th>
<th>weight_prefix</th>
</tr>
</thead>
<tbody>
<tr>
<td>30 Select</td>
<td>Red</td>
<td>2</td>
<td>Yes</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>+</td>
</tr>
<tr>
<td>30 Select</td>
<td>Blue</td>
<td>5</td>
<td>Yes</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>+</td>
</tr>
<tr>
<td>35 Large</td>
<td>15</td>
<td>Yes</td>
<td>15</td>
<td></td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>+</td>
</tr>
<tr>
<td>35 Small</td>
<td>0</td>
<td>Yes</td>
<td>5</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>+</td>
</tr>
<tr>
<td>35 Medium</td>
<td>10</td>
<td>Yes</td>
<td>10</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>0</td>
<td>+</td>
</tr>
<tr>
<td>42 Checkbox1</td>
<td>Yes</td>
<td>40</td>
<td>10</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>10</td>
<td>+</td>
</tr>
<tr>
<td>42 Checkbox2</td>
<td>Yes</td>
<td>194</td>
<td>20</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>20</td>
<td>+</td>
</tr>
<tr>
<td>42 Checkbox3</td>
<td>Yes</td>
<td>2606</td>
<td>30</td>
<td>+</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>+</td>
<td>30</td>
<td>+</td>
</tr>
</tbody>
</table>

- **product_id** - This is required field. And must be in numeric. To edit any product data enter valid product id else to insert new data use assumed product id as in previous tabs.
- **option** – Enter Valid option name. If not found full row will not inserted/update.
- **option_value** – Valid value of option name. If not found full row will not inserted/update.
- **quantity, price, points, weight** – Valid numeric value.
- **subtract** – Set “Yes” or “No”. Default No will be inserted if left blank.
- **price_prefix, points_prefix, weight_prefix** – Use “+” Plus or “-” Minus operator.
Template Products

By using template product sellers can give the different prices for products by which the minimum price product only visible for a particular product.

**For example:**

Three Sellers gave different prices to a template product let say

Seller1 = 150
Seller2 = 125
Seller3 = 99

The price of third seller only visible for product but the customer can buy a product for himself from seller1 even seller2.

**How can admin create the template product?**

- First step to enable the template product from Admin > Multivendor > Settings > Seller tab > “Use Product Template” select yes then click to Save blue color button on right side corner.
### Seller Product Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show seller information on order success page</td>
<td>No</td>
</tr>
<tr>
<td>Show seller name on product list</td>
<td>No</td>
</tr>
<tr>
<td>Show seller address on product list</td>
<td>No</td>
</tr>
<tr>
<td>Show seller detail on product page</td>
<td>No</td>
</tr>
<tr>
<td>Show seller on category page</td>
<td>Normal Mode</td>
</tr>
<tr>
<td>Allow seller to add template product description</td>
<td>Yes</td>
</tr>
<tr>
<td>Show Seller template product price list on product page</td>
<td>Yes</td>
</tr>
<tr>
<td>Seller Store Page Layout</td>
<td>Layout 1</td>
</tr>
<tr>
<td>Products View</td>
<td>List</td>
</tr>
<tr>
<td>Use Smart Product Form</td>
<td>No</td>
</tr>
<tr>
<td>Allow seller to reply customers</td>
<td>No</td>
</tr>
</tbody>
</table>

#### Use Product Templates

- **Yes**

**Additional Seller Settings**

- **Max. number of seller products allowed**: 10

**Seller Review Settings**

- **Seller review enabled**: No

**Seller Contact Settings**

- **Seller contact mode**: General

**Seller Blog Settings**

- **Sort by**: Sort order

**Seller Store Options**

- **Fields to show**: Seller name, Store email, Store phone, Store address, Social Links
- **Invoice/Shipping generated by seller**: No
- **Hide customer details from seller**: Yes

---

**Version**: 3.1.12

---

**OpenCart © 2005-2022. All Rights Reserved.**
**Version**: 3.0.3.2
• After enable the product template then the two menus will appear in admin "Product templates" and "Seller Product Templates"
• If you want to show seller price list instead of “add to cart” then you have to set "Show Seller template product price list on product page" to "Yes".
• From product templates admin can create the template products from here also can assign them to single or multiple sellers.
• To create the template click to add blue button on right side corner.

Assign product template to sellers.
• Admin can assign a template to multiple sellers.
• Click to blue color add button in “Product detail” column.
Select seller from auto complete dropdown, fill Quantity, Price, Stock Status, Subtract stock, Status and option. Admin can select only "radio" and "select" option type in seller template product. Other types of option will not show in seller template product option. For this, Seller template option will have to be defined in template product option.

After that we can use option in seller template product. We can select only those option values in seller template product option which are defined in template product option. After it we will have to select option value and fill the required values of seller template product like Option value, Quantity, Subtract and Price. Then click on blue color save button.
After assigning templates will appear in the Seller Product Templates admin menu.
How sellers can assign prices, quantity and other details to their templates?

- Goto Seller Options > Catalog > Product Templates.

- These are the product templates which are created by admin for sellers. Click to edit button to assign Price, Quantity and Other details to templates.

- From here, seller can assign Price, Quantity, subtract stock, Out of stock status, Template Status and option. Seller can select only "radio" and "select" option type in seller template product option. Other types of option will not show here. For this, Seller template option will have to be defined in template product option.

- After that seller can use option in seller template product. We can select only those options values in seller template product option. Which are defined in the template product option. Seller will have to select option value and fill the required values of seller template product like Option value, Quantity, Subtract and Price. Then click to save button.
• Assigned templates appear in light green color.

Setup Multivendor Seller Price module.
  • Go to Admin > Extensions > Extensions > Modules > Scroll down > "Multivendor Seller Price” click to green color install button Then click to blue color edit button.

  
  
  
  | Multivendor Featured Stores | Disabled |  
  | Multivendor Seller Billing Setting | Disabled |  
  | Multivendor Seller Details | Enabled |  
  | Multivendor Seller Featured Products | Disabled |  
  | Multivendor Seller Price | Enabled |  
  | Multivendor Sellers Latest Products | Disabled |  
  | Multivendor Settings | Enabled |  
  | POS Settings | Disabled |  
  | PayPal (Powered by Braintree) Button | Disabled |  
  | PayPal Express Checkout Button | Disabled |  
  | PayPal Checkout Button | Disabled |  
  | Sagepay Direct Card Management | Disabled |

• Select “Enable” from dropdown then save it.
• Now, Go to Admin > Design > Layout > Product. Then edit “Product”.

• Select Multivendor Seller Price from dropdown then click to save button.
Now go to home page of website then look for product which seller is assigned their own product details or by admin. On this page the multiple seller’s price is visible.

List of different seller's product price.
If template product has *radio* or *select* option and we click on the radio option, then, we will get sorted seller price list according to the seller options automatically.
If we select "Show Seller template product price list on product page" option "Yes" from admin settings, then we will get seller price list instead of add to cart button.

Managing Downloadable Product via Seller Panel

Seller can create Downloadable Items and can assign them to product.

   a. **Admin Side** – Admin can assign seller to any downloadable item.
      1. Login to admin Panel
      2. Go to Catalog > Downloads.
      3. In here you will see 1 extra column of "**Seller Store Name**".
4. Add or edit any item.
5. Select Seller Store name from dropdown. This is required field. For admin product items select "N/A".
6. Save the item and now seller can assign this item to their products.

a. **Seller Side** – Seller can also create downloadable items which can only be assigned to their products by seller.
   1. Login to seller Panel.
   2. Click on Manage Downloads.
   3. In here add/edit or delete Downloadable items.
4. Create or edit any item.
5. Enter Download Name.
6. Upload Valid Filename and mask.
7. Save the item.

- When seller Add/edit any product, now they can only add downloadable items available for their store only.
- Each Seller can create there downloadable items and can only assign to their products only.
Live Chat Module

Customers can chat directly with Sellers using this module. Admin can activate chat module, then sellers can configure their chat accounts from dashboard. After that, live chat window appears on seller products and seller store pages. When a user puts enquiry on the chat window, it goes directly to chat agent on seller's side.

Admin Configuration

Extension configuration

- Go to Opencart admin Panel > Multivendor>Setting > General Tab > Allow Tawk.to Live Chat Select Yes.

Configuring Seller’s chat account

This can also be done by seller from Seller Dashboard.

- Go to Multivendor > Manage Stores > Click on Edit Store button.
• Click On "Live Chat" Tab on Right Side Corner.
• Choose Allow Tawk.to Live Chat to “Yes” and save the settings.
• Create account on tawk.to.
• Go to tawk.to admin and go to the Script Code from Widget Code Textbox.

In below example useful “Widget Code” script.
Example -

```html
<!--Start of Tawk.to Script-->
<script type="text/javascript">
  $(document).ready(function()

```
Now You Can See the Live Chat Popup on Product Page and Seller Page.
MacBook Air is ultra thin, ultra portable, and ultra unlike anything else. But you don’t lose inches and pounds overnight. It’s the result of rethinking conventions. Of multiple wireless innovations. And of breakthrough design. With MacBook Air, mobile computing suddenly has a new standard.
Seller side configuration

- Login to Seller Panel.
- In Seller Options Click on “Store Information”.

- Scroll Down Below
- Choose Allow Tawk.to Live Chat to “Yes”.
- Add Tawk.to Widget Code from tawk account.
- In below example use full “Widget Code” scriptExample -

```
<!--Start of Tawk.to Script-->
<script type="text/javascript">
var Tawk_API=Tawk_API||{}, Tawk_LoadStart=new Date();
(function(){
var s1=document.createElement("script"),s0=document.getElementsByTagName("script")[0];
  s1.async=true;
  s1.src='https://embed.tawk.to/fdfdfdf43434345/default';
  s1.charset='UTF-8';
  s1.setAttribute('crossorigin','*');
  s0.parentNode.insertBefore(s1,s0);
})();
</script>
<!--End of Tawk.to Script-->
```

---

<---

_widget_code

<table>
<thead>
<tr>
<th>Allow Tawk.to Live Chat</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tawk.to Widget Code</td>
<td></td>
</tr>
</tbody>
</table>
• Now you can see the Live Chat Popup in Right Side Corner on Product and Store page for the seller.

Customer Enquiries module
Using this module, messaging between user and seller happens. User can send message and seller can reply to them. When “Logged-in mode” is enabled, all the communication happens on portal without sharing email id between seller and customer.

Admin settings
Goto- Multivendor-> Setting> Seller tab as shown below.
After that select seller contact mode “General” or “Logged In”.

- In Logged In mode Customer must be logged in to raise customer enquiry to seller and seller can reply from seller panel to any customer.
- In General mode any guest can raise query to seller and seller replies on email, not from seller panel.
- Email Notification is always sent to seller and customer on new message.

Delete all information of seller

- To delete all information of seller go to Admin > Multivendor > Sellers > Click to red color delete button. Then the page will redirect to confirm seller delete page.
- If you check the delete product then the product will delete from everywhere if leave as blank then the product will assign to admin.

Customer Side
- Customer can contact any seller by clicking on Contact Seller from Store page and Product page
• In General Mode Guest will fill the form with Customer Name, Customer Email and Enquiry.
• This Message will be visible to Seller in Seller panel, but seller can only view email id of guest and message. Seller will not be able to reply guest from seller panel.

• In Logged in Mode. Customer must be logged in and can raise any enquiry to seller. If customer had already contacted seller in past then. All the conversation between them is visible on this page.
Customer can View List of enquiries made to multiple sellers by clicking on Seller contact in right menu after logged in.

On Listing page customer can view last message send or received. To view all messages click on View All.
- In Logged in Mode. Customer must be logged in and can raise any enquiry to seller. If customer had already contacted seller in past then. All the conversation between them is visible on this page.

- Customer can also can attach a file with enquires message
**General Mode.**
If customer click the contact seller. Customer will reach on customer enquiries form. Here customer write his/her message and attach a file with enquiries message.

**Logged In Mode**
If admin has set logged in mode then customer will have to login first. After Login, **you** will see following message box with attach feature.
When you will send message to seller then you will get message list on above of Enquiries field.
## Customer Enquiries

<table>
<thead>
<tr>
<th>Customer</th>
<th>Enquiry</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>customer1 demo</td>
<td>hi</td>
<td>16/10/2020</td>
</tr>
<tr>
<td>Seller2 demo</td>
<td>testing</td>
<td>16/10/2020</td>
</tr>
<tr>
<td>customer1 demo</td>
<td>ok</td>
<td>16/10/2020</td>
</tr>
</tbody>
</table>

### Attached files

- green.png
- red.jpg
- blue.jpg
- red.jpg
- hh3.jpg

---

### Attach file

- Upload file
- Action

[Submit]
Seller Side

- Seller can view list of Customer enquiries by clicking on Customer enquiries on seller panel.
- All Guest Enquiries in here would be shown as one and seller can only view Guest enquiries by clicking View All.
- On Listing page only last message of last guest user and last message of customer if enquiry is raised by logged in customer.

**Customer Enquiries**

<table>
<thead>
<tr>
<th>Seller demo1</th>
<th>View All</th>
</tr>
</thead>
<tbody>
<tr>
<td>this is customer seller demo</td>
<td>03/07/2018</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Guest</th>
<th>View All</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guest</td>
<td>03/07/2018</td>
</tr>
</tbody>
</table>

- On Clicking View All Seller can view conversation between customer and them and can reply to customer.
- Seller will not be able to reply to guest users.
- Email Notification is sent to customer if seller reply to any query.
- Seller can also attach a file with customer enquires message
  - Seller can see messages and attached file in enquires message.
  - Go to Seller login > Customer enquiries > List of messages. Here, seller can see all message with attachment file.
Subscription Plan module

Using this module, Seller has to subscribe to Subscription plans to add products, Seller can only add products according to the Plan Subscribed by them.

Admin settings
Goto Multivendor -> Setting > subscription Tab as shown below.
Now Goto Subscription Plan Heading
Fields in the Subscription Plan are as follows:

- **Enable Subscription Plan** – Select “Yes” to Enable the subscription plan, if set to “No”. Functionality of Subscription plan will not be visible for Admin and Seller but everything will work fine without any conditions.
- **Enable Subscription Fees** – If Set to “Yes” then the subscription fees assigned by admin to any plan will be assigned to Seller, if set to “No” Seller can buy Subscription plan at 0(Zero) subscription price.
- **Enable Joining Fees** – If Set to “Yes” then the joining fees assigned by admin to any plan will be assigned to Seller, if set to “No” Seller can buy Subscription plan at 0(Zero) joining price.
- **PayPal E-Mail ID** – Enter PayPal E-Mail ID of that E-Mail ID in here to give option to seller to pay via PayPal. If this field is left Blank then PayPal button will not be visible to seller on their invoice or Multivendor Payout Payment method will not be there on checkout.
• Tax Name – Enter any TAX name which has to be added in Seller Plan Invoice.
• Tax Value – Enter value in percent from 0 to 100 which will be added to subtotal of Subscription Plan.
• First Reminder (in Days, 0 to disable) – When Subscription Plan of any seller is expiring. An automated mail will be generated to Seller and Admin that there Plan is about to expire in X days. Just specify Days in this field for which this mail is to send.
• Second Reminder (in Days, 0 to disable) – When Subscription Plan of any seller is expiring. An automated mail will be generated to Seller and Admin that there Plan is about to expire in X days. Just specify Days in this field for which this mail is to send.
• Third Reminder (in Days, 0 to disable) – When Subscription Plan of any seller is expiring. An automated mail will be generated to Seller and Admin that there Plan is about to expire in X days. Just specify Days in this field for which this mail is to send.
• Grace Period – This is the days for which admin wants to increase days after the validity of plan as defined in admin for seller Subscribed Plan only if seller has not purchased or upgraded the current plan.
• Default Currency for PayPal – Select default currency for subscription plan payment

Add default currency for Subscription plan payment
• Add your currency from System > Localization > Currencies > Click to add button. Then add your currency click to save button.

Now, go to Multivendor > Settings > Scroll down > find Default Currency for PayPal.
• Select default currency from dropdown then click to save button
• Whenever seller pay subscription plan payment then the amount will convert into default currency

Adding Subscription Plans

Admin can add Subscription plans after enabling the subscription plan from setting.
Go to Multivendor > Subscription Plans

GENERAL

- Add New or edit previous plan.
- Plan Name – Name of Plan in Each Language in each tab is required.
- Description – Plan Description for each language. Use WYSIWYG editor. You can add detailed description of this plan in this field.
- Plan Short Description – This has also been added in each language. Try to keep it short as of just 1 or 2 lines as this will be visible on many pages on seller and admin side.

DATA

- Default Subscription Plan – Checked this option for create default subscription plan. Whenever new seller is registered then automatically enable the default subscription plan
- No of Products – Required field and must be number. Products which each seller can add according to their Plan in valid period.
• **Joining Fee** – Required field and must be number or decimal. One time fees for this subscription plan. If Seller changes the plan then difference between previous plan Joining Fees and New Plan Joining fees will be adjusted in total.
• **Subscription Fee** – Required field and must be number or decimal. This is the subscription fees for the plan for particular period as in Validity.
• **Validity** – Required field and must be number. Enter no of days for which this Plan will be valid.
• **Status** – Select Enabled to view this subscription Plan on Seller and admin side.

Admin Invoice Status of subscription Plan

Admin can add Invoice Status for Subscription plans which can be assigned to Invoice of Seller Subscription Plan.

• **Go to Multivendor > Invoice Status of Subscription Plan.**
• **There Are 2 Status which will be created when you install this extension or Upgrade the Database after installing.**
• “Pending” and “Complete” status cannot be deleted by admin. But this status can be edited.

• Admin can add/edit the invoice status.

• Status Name must be given in all Languages. This is required field.
Seller Pending Subscription Invoices

- The seller whose subscription invoice status is pending will be appear in Admin > Multivendor > Pending Subscription Invoices.

Admin Seller Subscription

- Admin can view Subscribed and not subscribed Seller from Manage Seller List.
- Go to Multivendor > Sellers
- In here admin can filter the list to view Subscribed and not Subscribed Sellers to any subscription Plans.
- Filter and Subscription button will only be visible if Subscription Plan is enabled from configuration.

- If Subscription Status is set to "All", then All sellers will be visible on list.
• If Subscription Status is set to “Subscribed”, then all sellers which are currently subscribe to any Plan and whose plan is not yet expired.
• If Subscription Status is Set to “Not Subscribed”, then All sellers which are currently not subscribed to any plan or of those whose plan has expired.
• Green Marked button means that the seller is or was subscribed to any plan, whose plan is active or even it is expired. Admin can view the subscription page of that seller by clicking on this button.
• Plus Sign means that the seller has not been assigned any Subscription plan at any time. Admin can assign any new plan to the seller by clicking on this button.

Add Subscription
• If seller is not subscribed to any plan then admin can add subscription plan for the seller from Manage Seller Page by clicking on Plus sign in front of each seller.

Select Plan from dropdown.
Select Subscription Status of seller. This can also be changed later in Seller subscriptions.
Admin cannot assign that plan if Products assigned to the seller are already more than the products that can be assigned in Plan selected.
So for that unassigned the seller products or Select Plan which has more products.
• Next will be the Confirmation page for plan selected with plan start and expiry date and total.
• TAX Name and value percent is to be as defined in Configuration.
• Click on Save and Generate Invoice button.

Seller Subscription
Admin can view list of Subscriptions by Sellers.
• Go to Multivendor > Seller Subscriptions

• Click on View Subscription button.
• Admin can view no of active plans for seller in "No of Active Plans "column.
Admin can change Subscription Status of seller. Select Enabled from Dropdown and click on Update button.
Admin can edit subscription plan – click on edit button.

Subscription Details – if currently subscribed then admin can see current subscribed plan details of the seller.
Admin can change payment history on click view button after that click on plus symbol button.
Invoices – In here list of subscription plans subscribed by seller and on top it will show currently subscribed or latest Seller subscription plan.

Assign/Change Seller Subscription Plan

- Admin can assign new subscription plan to seller.
- Click on Assign New Seller Plan button on top right.
- Now this page shows the Seller name and Current Plan of the seller.
- Select New Seller plan From Seller Plan
- Select Start Now to End the current subscription plan now and assign new subscription plan right now.
- Select Start at end of current Plan to start this plan as soon as the current subscribed plan expires.
- Select Subscription Status from down. This status can also be changed later.

- Admin cannot assign that plan if Products assigned to the seller are already more than the products that can be assigned in Plan selected.
- So for that unassigned the seller products or Select Plan which has more products.
- Admin can also not be able to assign any new plan to seller if previous seller plan is pending.
  So change the status of previous plan to assign new plan to seller.
- Next Page will the Confirmation page for selected plan with details.

- Next Page will the Confirmation page for selected plan with details.
- It will show Current Plan with Start and end date with Validity.
- New Plan Details with Start Date and End Date.
- In This Adjustment Joining Fees will be (Joining fees of new plan – Joining Fees of Previous plan). Means if previous plan has joining fees of $20 and new plan has joining fees of $30, so Total Adjusted Joining Fees will be $10, which will be added in subtotal and grand total.
- Adjustment Subscription Fees will be Pro Date bases, means if admin select Start Now then Remaining balance from previous subscription plan will be calculated bases on its expiry date or validity and it will be subtracted from Current Subscription price.

Example –
- Old Plan Subscription fees is $30 and New Plan Subscription fees is $40.
- If Start at end of Subscription Plan is selected then New Plan Subscription fees will be applied i.e. $40.
- If Start Now is selected and previous plan is yet to expire then Adjustment Subscription Charges will be New Plan Fees – Subscription fees for pending days for old plan.
- Total Can also be in Minus if selected plan is downgraded before expiry Date.
- Previous Balance is balance from previous invoice if grand total is in Negative value.
- TAX Name and value percent is to be as defined in Configuration.
- Grand Total will be (Adjustment joining fees + Adjustment Subscription fees) + tax percent + Previous Balance.

View Invoice
- Click on View button in front of each Invoice to view the invoice detail or to print the invoice.
The Invoice will have new Plan details along with Total charges for the subscription.

Add Payment/Change Invoice Status

- Admin Can Add Payment history to any invoice or can change status of invoice by click on Plus sign in front of each invoice.
Select Status from Dropdown for the invoice.
Enter Transaction id if admin is received payment from any offline mode. This can also be left blank if no reference id is available.
In Comment Section add any detail related to payment or this can be left blank also.
Click on save button to save the invoice payment.

Multiple Subscription Plans

Admin settings
Goto- Multivendor-> Setting as shown below.
Now Goto Subscription Plan Heading
  • Enable Multiple Subscription Plan – Select “Yes” to Enable the multiple subscription plan, if set to “No”. Functionality of Subscription plan will be work fine without any conditions.

Add multiple Subscription
  • Go to Multivendor > Seller Subscriptions
  • Click on View Subscription button.
Click on Assign New Seller Plan button on top right.
Now this page shows the Seller name and Current Plan of the seller.
Select New Seller Plan From Seller Plan
Select Subscription Status from down. This status can also be changed later.

Admin can also not be able to assign any new plan to seller if previous seller plan is pending.
So change the status of previous plan to assign new plan to seller.
Next Page will the Confirmation page for selected plan with details.
Next Page will the Confirmation page for selected plan with details.
It will show Current Plan with Start and end date with Validity
New Plan Details with Start Date and End Date.
Joining Fees will be (Joining fees of new plan)
Subscription Fees will be added in subtotal and grand total.
Admin tax will be added in subtotal and grand total.
Click Save & Generate Invoice

Subscription plan’s products, featured and category featured products

Admin Side

- Go to, products list page > click to edit any one product select to ’Vendor” tab. Choose any seller from vendor tab then subscription plan for product, subscription plan for featured product and subscription plan for category featured product dropdown will be visible. Otherwise, dropdown will not visible if set to none.
- Select subscription plan from dropdown then the plan will assign to product. Only those plans will show in dropdown which are currently active for selected seller.
- Then click on save button.
Assign Subscription plan to product from Store edit

- Go to MultiVendor -> Store
- Click on Edit store button
- Select Add Product Tab

- After that Check any product, then subscription plan popup will open.
- Thereafter select any subscription plan form popup to assign subscription plan for product then click save button.
Subscription Plan Seller Side

- Seller can subscribe to any Subscription plan
- Go to Seller Panel > Subscription Plan.
- Seller can view Currently Subscribed plan on top if any.
- Click on Subscribe button to subscribe to new plan or to change the plan.
- Active Plan can only be started at end of current plan by seller. So Click on Update button to subscribe current plan after expiry of current plan.
- All other plan can be started now or at end of current plan.
- On Seller Plan Confirmation Page select Start Now to start the plan now or Click on Start at end of current plan.
- It will show Current Plan with Start and end date with Validity
- New Plan Details with Start Date and End Date.
- In This Adjustment Joining Fees will be (Joining fees of new plan – Joining Fees of Previous plan). Means if previous plan has joining fees of $20 and new plan has joining fees of $30, so Total Adjusted Joining Fees will be $10, which will be added in subtotal and grand total.
- Adjustment Subscription Fees will be Pro Date bases, means if admin select Start Now then Remaining balance from previous subscription plan will be calculated bases on its expiry date or validity and it will be subtracted from Current Subscription price.
Example –
- Old Plan Subscription fees is $30 and New Plan Subscription fees is $40.
- If Start at end of Subscription Plan is selected then New Plan Subscription fees will be applied i.e. $40.
- If Start Now is selected and previous plan is yet to expire then Adjustment Subscription Charges will be New Plan Fees – Subscription fees for pending days for old plan.
- Total Can also be in Minus if selected plan is downgraded before expiry Date.
- Previous Balance is balance from previous invoice if grand total is in Negative value.
- TAX Name and value percent is to be as defined in Configuration.
- Grand Total will be (Adjustment joining fees + Adjustment Subscription fees) + tax percent + Previous Balance.

View Invoice
- Seller can view Invoice after Subscribing to Plan.
- Seller can make offline payment by clicking on Pay Offline if status of the Invoice is pending.
- Payment can also be made using PayPal. Click on PayPal button and complete the payment.
- PayPal E-Mail ID must be defined in Admin Multivendor configuration to view PayPal Button.
- If PayPal button id is not valid then PayPal page will show error else payment flow will work as usual for payment processing.
- If Invoice Status is complete, then Payment buttons will be visible.
- After Successful payment from PayPal, page will be redirect back to invoice page.
- Invoice will wait from PayPal to confirm the payment, and only then the status of Invoice will change with Transaction ID and other useful information from PayPal in comment and seller can view it after refreshing the invoice page.
Click on Pay Offline to make offline payment.

Sellers can only Enter Offline Payment Information as a comment. Only Admin can change the status and add any reference ID for the payment if received from offline mode.
Subscription Invoices

- Seller can view list of Subscribed Plan in past or current plan details.
- Go to seller panel > Subscription Invoice.
- Seller can view Invoice of any Plan.

Product Limit

- If Subscription Plan is disabled from admin Configuration, then. There is not any limit for any product addition.
- Seller can only add/edit products to their stores if following conditions met and If Subscription Plan is enabled from admin.
### Cron Setup for Seller Subscription

- Please put following entry in crontab for daily calculation of invoices etc. for subscription plan related data. Note the cron needs to run only once in a day.

```
0 8 * * * curl https://www.yourdomain.com/index.php?route=extension/account/Purpletree_Multivendor/subscriptioncron
```

### Multiple Subscription Plans

- Seller can subscribe to multiple Subscription plan
- Seller can assign Total number of product (No of product plan1 + No of product plan2)
- Seller can assign Total number of featured Products (No of featured product plan1 + No of featured product plan2)
- Seller can assign Total number of category featured product (No of category featured product plan1 + No of category featured product plan2)

**Go to Seller Panel > Subscription Plan.**

- Seller can view Currently Subscribed plans on who subscription plan have active status.
- Click on Subscribe button to subscribe to new plan.
- Active Plan can only be started at end of current plan by seller. So Click on Renew button to subscribe current plan after expiry of current plan.
- All other plan can be started now.

**On Seller Plan Confirmation Page select Start Now to start the plan now.**

- It will show New Plan with Start and end date with Validity
- Joining Fees will be (Joining fees of new plan), which will be added in subtotal and grand total.
- Subscription Fees will be added in subtotal and grand total.
- Admin tax will be added in subtotal and grand total.
- Click Save & Generate Invoice.
Subscription Plan’s Products, Featured and Category Featured Products

Seller Side
- Add Featured Products - Go to Seller option > Products > check add featured product for featured product module and then subscription popup will open then select the subscription plan for featured product. Seller can only assign featured product to particular subscription plan if limit of that subscription plan allows it. If the product is selected as featured then the product will not be edit and edit button will also not appear. For this functionality we have provide the choice go to Multivendor > Settings > Seller tab > “Featured enabled hide edit button” select “Yes” then the edit button will hide when selected as featured product if is not then work as normal.
• Add Category Featured Product - Go to Seller option > Products > check add category featured product for category page and then subscription popup will open then select the subscription plan for featured product. Seller can only assign featured product to particular subscription plan if limit of that subscription plan allows it.

• Then click on save button.

For Smart Product Form
Automatic SEO options

While adding products, the extension fills various SEO related fields automatically as mentioned below, if those fields are left empty while saving the product.

1. The **Title** Meta Tag is auto filled with Product name if left blank.
2. The **Description** Meta Tag is auto filled with Product Description if left blank.
3. The **Keywords** Meta Tag are auto filled with Product Tags with left blank.
4. **SEO URL** for the product is auto filled with product name if left blank.
Restricting No. of categories allowed for single product

Admin can control the number of categories that can be assigned by sellers when adding a single product, i.e. whether the seller should be able to assign the product to single category or to multiple categories.

**Note:** The categories which sellers can use for assigning products are controlled by a different setting. This setting explained here just talks about whether single or multiple categories can be assigned while managing products, on seller side.

**Steps for Admin**

- Go to Multivendor > setting> General Tab.
- Option ‘No. of categories allow for a single product’ here, There Are 2 Status.
- “Single” and “Multiple” by default multiple selected then seller add multiple categories add for single product when single selected then seller add single categories add for single product.
Now seller would be able to select wither multiple categories for every product, or a single category via a drop down.

**MULTIPLE CATEGORIES ALLOWED**

**SINGLE CATEGORY ALLOWED**
Featured Stores

Admin can highlight some seller stores as **Featured** in a carousel, to increase visibility of Seller Stores.

**Featured Stores** feature can be used by admin as a part of Subscription plans, to make earning from Sellers by allowing their stores to be listed as featured.

**Featured Stores** is essentially an Opencart Module position, which can be set from Admin Panel. All the store marked as featured would display inside the carousel on the position assigned to the module.

**Steps to configure and use Featured Stores**

**Enabling the Module**

- Go to extensions > extensions select ‘module’ from dropdown, scroll down below.
- You can see the Multivendor Featured Stores.
- Click to Install Icon Button.
- Click on Edit Button Next Left to install button.
• Enter product limit, enter product imageHeight, enter product image Width and select ‘Enabled’ From Dropdown. Click to Save Button.
• Now, Go to Design > Layouts.

• Scroll down Set Featured Product Module on ‘Home’ (if you want it to appear on the home page).

• Click to Edit Button.
• Scroll Down, In Content Top Block, Select Multivendor Featured Store Products and also you can set where you want.

![Content Top Block]

• Click to Save Icon Right Top on the Screen.

Adding Featured Stores to a Subscription Plan

1. Now go to Multivendor > Subscription Plan.
### Multivendor Settings

**Vendor settings**

- Admin user status for commission calculation: Complete
- Status of feature for refunded calculation: Refunded
- Shipping type: Free shipping
- Commission (in percent per product sold):
  - Fixed Commission: 0
  - Commissions for country:
    - France: 0
- Commission from seller group: No
- Commission from vendor level: France:
- Allow order to store orders: No
- Allow order status for seller's account:
  - Cancelled
  - Completed
  - Declined
  - Expired
- Allow customer to store orders: No
- Seller approval required: No
- Product approval required: No
- Allow category for seller: All categories
- No. of categories allowed for a single product: Multiples
- Show Seller Logos / Seller Panel Link: No
- Allow Team to Live Chat: No
- Enable Browse Sellers: No
- Hide User Menu for sellers: No
- Use domain wise stores: No

**Other Settings**

<table>
<thead>
<tr>
<th>General</th>
<th>Seller</th>
<th>Subscription</th>
<th>Development</th>
<th>Integration</th>
<th>Other Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Enabled</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Change License Key**

---

*OpenCart © 2005-2022 All Rights Reserved. Version 3.0.3.2*
2. Click to Add Subscription.

3. Go to Data tab.


5. Select 'Yes' from Dropdown.

6. Now, when creating subscription plans as Admin, you can mention whether a particular plan allows the seller Store to be marked as featured or not.

7. The sellers *who have subscribed to a subscription plan allowing featured stores*, have their stores visible in the Featured Store carousel.
Display latest products from sellers in a carousel

1. Go to Extensions > Extensions Select 'Module' From Dropdown, Scroll Down Below.

2. Click to Install Icon Button.
3. Then Click on Edit Button Next Left to install button.

4. Enter product limit, enter product image Height, enter product image Width and select 'Enabled' From Dropdown. Click to Save Button.
5. Now, Go to Design > Layouts.
6. Scroll down Set Featured Product Module on 'Home'.

7. Click to Edit Button.

8. Scroll Down, In Content Top Block, Select Multivendor Latest Featured Products. And also, you can set where you want.
9. Click on the **save** icon at right top corner of the screen.
10. Now, whenever any seller adds a product, it will automatically show in “Seller Latest Products” carousel.
11. Example: you can see it on the Homepage:
Seller Details module

Seller Details Module show seller information on seller’s product details page like Seller Name, Seller Reviews, Seller Social Links, Seller Email, Seller Telephone Number, Seller Address, About Store, Seller Store Shipping Policy and Seller Store Return Policy. Seller information show according to multivendor setting.

Enabling the Module
First of all user need to give the permission to Seller Details Module file. (extension/module/purpletree_sellerdetail).

Go to System>Users>Users Groups>select User Group and click on edit button. Give the permission to Seller Details Module file.

User can enable Seller Details Module two type.

- **Automatic enable Seller Details Module**
  - Go to extensions > extensions select ‘module’ from dropdown, scroll down below.
  - You can see the Multivendor Settings module, click on install button (when Multivendor Settings module not install) after that click on edit button.
  - You will reach on Multivendor Settings page, after that click on save button. Seller Details Module automatically install, enable and set on product detail page.

- **Manual enable Seller Details Module**
  - Go to extensions > extensions select ‘module’ from dropdown, scroll down below.
  - You can see the Multivendor Seller Details module, click on install button (when Multivendor Seller Details module not install) after that click on edit button.
  - You will reach on Seller Details page, after that click on save button. Seller Details Module automatically install, enable and set on product detail page.
  - Set Enabled status and click on save button.
- Now, Go to Design > Layouts.
- Scroll down Set Featured Product Module on ‘Product’.
- Click to Edit Button.
- Find column right, In Column Right Block, Select Multivendor Seller Details Module. And also, you can set where you want.
- Click on the save icon at right top corner of the screen.
- Now, Seller Details Module show on product detail page.
MacBook
Brands: Apple
Product Code: Product 18
Sold by: Demo Store
Seller Rating: ⭐⭐⭐⭐⭐ 0 Reviews
Contact Seller
Reward Points: 800
Availability: In Stock

$500.00
Ex Tax: $500.00
Qty: 1

Description
Intel Core 2 Duo processor
Powered by an Intel Core 2 Duo processor at speeds up to 2.4 GHz, the new MacBook is the fastest ever.

1GB memory, larger hard drives
The new MacBook now comes with 1GB of memory and larger hard drives for the ultimate in performance and speed. There is no better way to keep track of your important data and files.

Sticky, 1.08-inch-thin design
MacBook makes it easy to fit in the road thanks to its tough polycarbonate case. Built-in wireless technology, and innovative MagSafe Power Adapter that releases automatically if someone accidentally trips on the cord.

Reviews (0)

Add to Cart

Demo Seller

Contact Seller
Email Templates

In the email templates admin can customize email templates format and any Multivendor supported languages. In the email templates there are many default templates are created for admin, seller and customer emails in each language but Multivendor gives flexibility to edit them.

- In the listing of email templates title column, you can see on which case mail will send that will to seller, customer and admin.
To customize the email templates go to Admin > Multivendor > Seller E-mail > Click to Edit button.
Now, admin can change the whole template text other than the variables which start with underscore (_), in own language. Then click to save button. As you can see in the screenshot below.
If admin decided to reset the template as like default, Admin just need to click on the blue reset button on right side of the corner. Then template will update with default text.
Managing Featured Products

Enabling the module

1. Go to Extensions > Extensions Select ‘Module’ From Dropdown, Scroll Down Below.

2. Find Multivendor Seller Featured Products.
3. Click to Install Icon Button.
4. Then Click on Edit Button, Next Left to install button.

5. Enter product limit, enter product imageHeight, enter product Image Width and select ‘Enabled’ From Dropdown. Click to Save Button.

7. Now, Go to Design > Layouts.
8. Scroll down and click on 'Home' Edit Button.

9. Scroll down, in Content Top Block, select Multivendor Seller Featured Products. Now you can set this module to any position you like.
10. Click on Save Icon.

Adding featured products in subscription plans
1. Go to Multivendor > Subscription Plan.
2. Add or edit a plan.
3. Go to Data Tab.
5. Set the Limit of Featured Products.
Adding product to featured carousel by seller

1. If Seller Subscription Plan is Enabled, then Seller can only add the limited products because depends on Subscription Plan.
2. Go to Seller Options.
3. Click on ‘Products’ menu.
4. Seller Can Add their Products to Featured Products by Checking The ‘Featured Product for Carousel’ Checkbox.

<table>
<thead>
<tr>
<th>Image</th>
<th>Product Name</th>
<th>Model</th>
<th>Price</th>
<th>Quantity</th>
<th>Status</th>
<th>Is Approved</th>
<th>Featured Product for Carousel</th>
<th>Featured Product for category page</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Canon EOS 5D</td>
<td>Product 3</td>
<td>100</td>
<td>207</td>
<td>Enabled</td>
<td>Yes</td>
<td>✅</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>HP LP3065</td>
<td>Product 21</td>
<td>100</td>
<td>1000</td>
<td>Enabled</td>
<td>Yes</td>
<td>✅</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>iMac</td>
<td>Product 14</td>
<td>100</td>
<td>977</td>
<td>Enabled</td>
<td>Yes</td>
<td>✅</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPhone</td>
<td>product 11</td>
<td>101</td>
<td>976</td>
<td>Enabled</td>
<td>Yes</td>
<td>✅</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MacBook</td>
<td>Product 16</td>
<td>500</td>
<td>929</td>
<td>Enabled</td>
<td>Yes</td>
<td>✅</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Nikon D300</td>
<td>Product 4</td>
<td>80</td>
<td>1000</td>
<td>Enabled</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shoes</td>
<td></td>
<td>0</td>
<td>1</td>
<td>Enabled</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. There is another way to add their Products to Featured Products, by enabling it from Data tab in product data tab.

6. Now you can see the Featured products on the carousel.
Seller Featured Products

iMac
Just when you thought...
$100.00
Ex Tax $100.00

HP LP3065
Stop your co-workers...
$100.00
Ex Tax $100.00

iPhone
iPhone is a revolution...
$101.00
Ex Tax $101.00

MacBook
Intel Core 2 Duo p...
$100.00
Ex Tax $100.00
Featured products for category page

Enabling the module

1. Go to Extensions > Extensions Select ‘Module’ From Dropdown, Scroll Down Below.

![Module Selection](image1)

2. Find Multivendor Category Seller Featured Products.
3. Click to Install Icon Button.
4. Then Click on Edit Button, Next Left to install button.

![Module Edit](image2)

5. Enter product limit, enter product imageHeight, enter product image Width and select ‘Enabled’ From Dropdown. Click to Save Button.

6. Now, Go to Design > Layouts.
11. Scroll down Click on ‘Category’ Edit Button.

12. Scroll Down, In Content Top Block, Select Multivendor Category Seller Featured Products. Now you can set this module to any position you like.
13. Click on Save Icon.

Seller side management

Seller can show his products on top of the website’s category page. These products are called **Category featured products**. Seller can avail this facility only if the subscription plan of the seller allows for it.

Example:
### Current Plan

<table>
<thead>
<tr>
<th>Selected Plan:</th>
<th>plancc</th>
</tr>
</thead>
<tbody>
<tr>
<td>Started Date:</td>
<td>04/09/2018</td>
</tr>
<tr>
<td>End Date:</td>
<td>14/09/2018</td>
</tr>
<tr>
<td>Subscription Status:</td>
<td>Enabled</td>
</tr>
<tr>
<td><strong>Featured Products:</strong></td>
<td>5/100</td>
</tr>
<tr>
<td><strong>Category Featured Products:</strong></td>
<td>2/100</td>
</tr>
<tr>
<td>Total Products allowed:</td>
<td>10</td>
</tr>
<tr>
<td>Used Products:</td>
<td>7</td>
</tr>
<tr>
<td>Invoice Status:</td>
<td>Complete</td>
</tr>
<tr>
<td><strong>Featured Store:</strong></td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Subscription Plans

**Active: plancc**

<table>
<thead>
<tr>
<th>No. Of Products:</th>
<th>10 Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joining Fees:</td>
<td>$100.00</td>
</tr>
<tr>
<td>Subscription Fees:</td>
<td>$10.00</td>
</tr>
<tr>
<td>Validity (in days):</td>
<td>10 Days</td>
</tr>
<tr>
<td><strong>Featured Products:</strong></td>
<td>100</td>
</tr>
<tr>
<td><strong>Category Featured Products:</strong></td>
<td>100</td>
</tr>
<tr>
<td><strong>Featured Store:</strong></td>
<td>Yes</td>
</tr>
</tbody>
</table>
**STEPS TO ADD CATEGORY FEATURED PRODUCTS BY SELLER**

**Method-1**

From the “Products” grid in the seller panel, seller can select products to include.

![Product Grid](image)

**Method-2**

Add or Edit any Product and set ‘Yes’ for the field **Category Featured Product**.

![Product Data](image)
Now you can see the Featured Category Products on Category Page.

Admin side management for Category Featured Products

While adding/editing a subscription plan, admin can give a number, for how many Category Featured Products are to be allowed for that plan.
Sellers Blogs

Sellers can add blog posts on the website using this module.
Admin and Sellers both can add/edit/delete blogs and manage blog comments.

Enabling the module


2. Click on a) Green button to install the module and then b) on Blue button to edit the module.

3. Here give the module a name (which will be displayed on the frontend) and set the status to ‘Enabled’. You can update other options according to your need.

4. Now click on the ‘Save’ button on the upper right corner.

5. Now you have to give access permission to the admin. So go to ‘System->Users->User Groups’ and edit ‘Admin’ permissions.
5. Click on SELECT ALL for Access and modify permissions, and click on the ‘Save’ button on the upper right corner on the page.
Now you should see the ‘Seller Blog’ menu in left column under Multivendor

6. Now, set the position of seller blog module in front. Here I am going to set it on ‘Home’ page. Go to ‘Design->Layouts’ and select the page you want to seller blog being shown on.
7. Choose the position and select the 'Multivendor Seller Blog setting' from dropdown. And save the changes.
Managing Blogs as Admin

For Seller blog posts, select ‘Seller Blog>Blog’ from ‘Multivendor’ in left menu.

To add a new post, click on ‘Add’ button on the right upper corner. Fill the form and hit the save button.
• To make a copy of a post, just select post/posts by checkbox and click on ‘Copy’ button on the right upper corner. Similarly, you can perform delete action.
• To edit a post, click on the ‘Edit’ button as specified in the screenshot.
For comments, select 'Comments from 'Multivendor>Seller Blog' in left menu.

Here you can add new comments to the posts delete them and approve an old comment from 'User Side'.

Fill the form and click on 'Save' button on the right corner of the page.
Managing Blogs as a Seller

1. For blog posts, select ‘Blog’ in Seller Option right menu.

2. To add a new post, click on ‘Add’ button on the right upper corner. Fill the form and hit the save button.
3. To make a copy of a blog post, just select blog post/blog posts by checkbox and click on 'Copy' button on the right upper corner. Similarly you can perform delete action.
4. To edit a blog post, click on the ‘Edit’ button as specified in the screenshot.
5. For comment to click on ‘Blog Comment’ option in seller options menu.
6. To filter the comment use filter option as specified in the screen shot.
7. To view comment on blog, click on view button
Frontend view of Blogs

Blog List

All Blog Post
Click on View all button.
Single Blog Post

Introduction

The Canon EOS 200D is Canon's first DSLR camera with the world's fastest DIGIC processor. The 24-megapixel EOS 200D includes Dual Pixel CMOS AF for the world's fastest live view focusing, an 8.5-cm (3.33") screen with touch-control capabilities, and 4K video recording. The camera's price, ISO range of 100-25,600 (expandable to 51,200), integrated scene modes, Wi-Fi, Face Detection and AI Servo continuous shooting, and Bluetooth, NFC, and GPS connectivity. This 200D video mode offers 1080p Full HD recording at 60fps/30fps 4:2:2/4:2:0 with full manual control over exposure and gain.

The Canon EOS 200D is available in three colors: classic Canon Black, White, and Silver (in Europe only). The EOS 200D can also be purchased with EF-S 18-55mm f/3.5-5.6 IS STM and EF-S 55-200mm f/4-5.6 IS STM kit. In the USA, the Canon EOS Rebel SL2 has a retail price of $1,149.00 for body only and $1,649.00 with the Canon EF 50mm f/1.8 STM lens.
Handling Commissions & Commission Invoices

Admin of the marketplace receives payment from the customers, receives commission for sales made, and the payout is later paid to sellers.

Admin can generate commission invoice, by selecting order items.

1. Go to Multivendor-> Commissions'.

2. Firstly you should select seller store after that click on filter button. You will get all orders of selected seller.

3. Now select the order items for which you want to generate commission invoice, and then click on Generate Invoice button.

4. Admin can only generate invoice for particular order item only once.

5. Items marked in green indicate that commission invoice has been already generated, so admin will not be able to generate commission invoice for those items.

Commission Invoice Details

Admin can manage commission invoice.

   a. Go to Multivendor-> Commission Invoice.
   b. After clicking on commission invoice, admin gets following web page.
1. Firstly, you should select seller store after that click on filter button. You will get all Commission Invoice of selected seller.
2. After that click on View button to get all detail of selected commission invoice. Admin will get following web page.

3. Important: Payouts are made for every commission invoice. This means, if the order amount was 100 USD, and commission was 20 USD, the payout of 80 USD can be made from inside the commission invoice itself. This helps in keeping track of the payout made, on per invoice basis.
4. Admin will deduct commission from total amount and pay the rest amount to the seller.
5. Admin can make payment settlement Offline and by PayPal.
6. Click on Pay Offline button For Offline payment settlement after that admin gets following web page.
7. Admin can make offline payment settlement and can edit offline payment history.
8. Click on add button for offline payment settlement. You get following web page.

9. Admin should fill up all details carefully. If Payment status is Complete, then ‘Pay Offline’ and ‘PayPal’ button will not visible.
10. Click on save button to save details of offline payment settlement. And page redirects to payment history page.
11. Amin can edit payments history and change transaction id, status, comment etc.
12. Click on Edit button to change detail of commission payment settlement.

13. Click on save button to edit detail of offline payment settlement. And page redirects to payment history page.

14. After that we will go to second part of payment settlement.
Firstly you should check PayPal detail on store page.

15. Go to Multivendor->Store.

16. Click on PayPal Detail tab. You will get a text box.

17. Fill valid PayPal Email ID and save it.

**Note:** Seller needs to provide Valid PayPal Email ID from PayPal account, by creating new account.

18. After the PayPal Email id for the seller is available, you see PayPal button on commission invoice page.
19. If PayPal Email ID text field is blank then PayPal button will not be visible on the commission invoice page.

20. Click on PayPal button for payment settlement.

21. After commission invoice payment settlement admin can print commission invoice. Commission invoice page image given below.
Multivendor Paypal Payout for Split Payment

- Using Multivendor PayPal Payout Payment method. Admin don't need to worry about seller payment. When customer places an order using this method. Seller Payment is made automatically to all sellers whose product is added in cart. Payment from customer must be Successful for PayPal Payout to initiate Payout to all seller. Seller must have valid PayPal Account and valid PayPal Email ID must be added by Seller for successful payment to sellers.

How to Configure Multivendor PayPal Payout Payment Method

- Enable PayPal payouts for the website admin’s PayPal account from [https://www.paypal.com/payoutsweb/landing](https://www.paypal.com/payoutsweb/landing). PayPal takes a couple of days to enable Payouts feature, after receiving the request. After you have PayPal Payouts enabled, proceed with next steps.
- Login to admin Panel and go to Extensions > Extensions.
- Choose the extension type as Payments.
- From the list find Multivendor PayPal Payments Payouts and click on Edit button.
From edit page Enter all the following fields-

- **E-mail** – Enter Valid Email ID of admin which will capture payment from customer.
- **PayPal Client ID** – Enter valid Client id from your PayPal Account. For more info check this link - [https://developer.paypal.com/docs/integration/admin/manage-apps/#create-or-edit-sandbox-and-live-apps](https://developer.paypal.com/docs/integration/admin/manage-apps/#create-or-edit-sandbox-and-live-apps)
- **PayPal Secret** – Enter valid Secret Key from your PayPal Account. For more info check this link - [https://developer.paypal.com/docs/integration/admin/manage-apps/#create-or-edit-sandbox-and-live-apps](https://developer.paypal.com/docs/integration/admin/manage-apps/#create-or-edit-sandbox-and-live-apps)
- **Sandbox Mode** – Set this to No for Production website. Enable it for testing purpose only while using Sandbox credentials.
- **Debug Mode** – This is Developer option for Testing purpose only.
- **Transaction Type** – Choose from **Authorization** and **Sale** option as provided by PayPal.
- **Total** – Enter Total amount for which if want to show this payment method to customer.
- **Geo Zone** – Choose from Geo Zone for which this payment method should be visible.
- **Status** – **Enabled** the status for using this method.
- **Sort Order** – Sort order for showing in which order on Checkout page.
How to Configure Payment for PayPal Account for Each Seller –
  - Seller should login to their Seller panel and go to **Store Information** and enter **Valid PayPal E-Mail ID**
Admin Can also Enter Seller PayPal Email ID from Admin > Multivendor > Stores > Select and Edit Store.

Click on PayPal Details Tab and Enter Valid PayPal Email ID of the Seller and Save the Store.

- During Checkout if The Multivendor PayPal Payout Payments Method is enabled and configured properly and all the added products in cart are of sellers whose PayPal Email ID is there then Multivendor PayPal Payout Payment method will be visible to Customer on checkout. It is up to the end user customer if they want to Use this payment method or use another payment method.
- After payment is complete, payment goes directly to the sellers, and commission to admin.
- Seller payment will be split to all sellers and commission would go to admin only if customer used Multivendor PayPal Payments Payouts method and the payment is successfully captured at the end.
- If the payment made to sellers using PayPalPayouts is successful, then invoices would be in complete status, else it would be pending even after initiating the payment, as sometimes PayPal is not able to verify Payouts at the same time.
  - The button "Update PayPalPayoutStatus” can be used later to update the status, as explained below.

How to Update Paypal Payout Status
- If Order Payment is done using Multivendor PayPal Payout Payment Method and Payouts to seller are still pending, then we have given an option to update the Payout Status for Each order.
- Go to Admin > Multivendor > Seller Orders. Select and View Order.
- On Order detail page there is Button on Top as Update PayPal Payout Status. Click on this button to update the status of this order for Payouts related to this order.
- Please note that this button will only be visible if Payment method used by customer for this order is Multivendor PayPal Payouts.
Orders

Order Details
- Your Store
- 27/1/2019
- Purpletree PayPal Payouts
- Flat Shipping Rate

Customer Details
- first lastL
- Default
- ptcmodemo1@gmail.com
- 123456799

Options
- Invoice
- Reward Points: 400
- Affiliate: $0.00

Payment Address
- demoFirst lastName
- address 123
- Nokia 160002

Shipping Address
- demoFirst lastName
- address 123
- Nokia 160002

Payout Payout Status updated successfully for Seller Payments.
• If all go well success message will show that Multivendor **Payout Status Updated Successfully for Seller Payments.**
• To Check the Current status of Commission Invoice Go to Admin > Multivendor > Commission Invoice. And select from list to view.
• Click on Transaction History of It is Complete else Pay Offline to view and add new Transaction for the invoice.

![Commission Invoice](image)

• If Payment was successful then Transaction ID will be on transaction id and other details regarding the payout is on Comment section and Status would have been saved as Complete.
• If Payment was pending not complete due to one or other reason than Transaction ID would show the Payout Status and Status would be pending for this invoice.

**Using Stripe Direct Payments for Vendors**

Stripe payment method has been developed by Purpletree, for direct payment into vendor’s stripe accounts.

We support Stripe Express Accounts for direct payment to vendor’s stripe accounts.

When Stripe payment is enabled, transfer of money into vendor’s account is initiated as soon as the order is placed. At the same time, transfer of commission is initiated into admin’s stripe account.

Note that actual arrival of money into the bank account of vendor is controlled by Stripe policies. Multivendor extension merely initiates the transfer.

To install and Setting of Stripe payment method:
Go to admin > Extension > Payments > Purpletree Stripe Payments > Edit
In Order Status Tab also, Set Complete Status for your Complete Status. It means, order will be marked as Complete when payment is successful from the customer.

Get above Credentials from your stripe account https://dashboard.stripe.com/apikeys
Get Live or Test Publishable Key and Secret Key from Developers > API Keys.
To Get Client ID Go to Stripe Settings then In Connect Click Settings From there you can get Live or Test mode client ID:

Admin also has to set Redirect URL which will be the URL after Seller successfully Connect their account to Admin account for Stripe Payouts. On this page Add URL for that as https://www.example.com/index.php?route=extension/account/purpletree_multivendor/stripeconnect (replace example.com with your website URL).

Following URL must be same as above. If you have more than 1 Redirect URL in here, make sure that Default is set to proper URL, otherwise Stripe payout will not work properly.
If Purpletree Stripe Payment is enabled by Admin then Seller can Connect to Stripe by From Seller side to Stripe connect.

Go to: Seller panel > stripe connect or Dashboard > connect
After filling the Seller Business Information in the Connect Form, Seller Stripe Account would be successfully connected to Admin Account for Stripe payouts. Seller would be redirected to Seller Dashboard after that and done.

And once Stripe account of seller is connected now instead of Stripe Link Stripe Connected without Link would come in Dashboard as in below screenshot.
Once Seller Stripe account is Connected, Admin can check that the Seller connected account comes which comes under Admin stripe account in **connected accounts** as below and its status must be **Complete** for Stripe Payouts to work.

Stripe payment method will come on checkout page if it's enabled.
If there are seller products in the order and Seller had successfully connected the Stripe from Seller panel, then admin stripe account would send Payment to all sellers after deducting Admin commission automatically. And seller commission invoice would also be generated automatically.
Product Returns

- Go to admin panel and select Multivendor setting select "Admin Action for which Refund will calculate" option for seller return product. Click on save button.

- Login as a customer and order seller product.
  - Go to go to my account link and click on it.
  - Select Order history and view order and click on return link.
  - Customer will reach on return form page fill all information and click on submit button.
Your Store

Account

Order Details
Order ID: #9064
Date Added: 31/05/2015
Payment Method: Cash On Delivery
Shipping Method: Flat Shipping Rate

Payment Address
Deom customer
deom
deom
deom42434234
Uttar Pradesh
India

Shipping Address
Deom customer
deom
deom
deom42434234
Uttar Pradesh
India

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Model</th>
<th>Quantity</th>
<th>Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canon EOS 5D - Select Line</td>
<td>Product 3</td>
<td>1</td>
<td>$80.00</td>
<td>$80.00</td>
</tr>
<tr>
<td>iPhone</td>
<td>product 11</td>
<td>1</td>
<td>$101.00</td>
<td>$101.00</td>
</tr>
</tbody>
</table>

Sub-Total $181.00
Flat Shipping Rate $5.00
Refunded $50.00
Total $106.00

Order History

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Date Added</th>
<th>Status</th>
<th>Comment</th>
<th>Updated By</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>31/05/2019</td>
<td>Pending</td>
<td></td>
<td>Admin</td>
</tr>
<tr>
<td>Canon EOS 5D</td>
<td>31/05/2019</td>
<td>Pending</td>
<td></td>
<td>Demo Store</td>
</tr>
</tbody>
</table>
Return request view for seller

- Login as a seller go to seller options menu and select Sales > Returns click on it.
- After clicking on Returns option in Seller option menu seller will be reach on Product Returns page. Return product request list show here.
- Click on view button and seller will reach on refund detail page.
  - Here seller can view all detail related to order and related to product information.
  - Here seller can change return status.
Admin side process for return

- Login admin panel go to sales > select Returns.
Select returns request and click on edit button and changed action like refund same as Multivendor setting’s option “Status of Return for refund calculation”.
After changed return action as refunded and refund amount calculated. Refunded amount view on order detail page customer, seller and admin side. Refunded amount subtracted with total amount.

If the seller added Return Status then the seller's Return status show on Product Return History with the seller store name and store link.
- Seller Commission and Commission invoice automatically updated according to the refund amount.
- Refund amount is display on seller order. Go to navigation menu and select Multivendor > Seller order
- Click on view button to view all information related to order like refund
- Admin can update refund amount by using update button
- After click on update button refund amount update popup open
- Admin can enter the price and click on submit button to update price.
Orders

Order Details
- Your Store
- 06/06/2019
- Cash On Delivery
- Flat Shipping Rate

Customer Details
- demo cust:123
demo
demo city
demo
Uttar Pradesh
India

Customer Details
- Default
- ptdsdemodemo@gmail.com
- 123-4567800

Options
- Invoice
- Reward Points: 400
- Affiliate: $0.00

Order (#27)

<table>
<thead>
<tr>
<th>Payment Address</th>
<th>Shipping Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>demo cust:123</td>
<td>demo cust:123</td>
</tr>
<tr>
<td>demo</td>
<td>demo</td>
</tr>
<tr>
<td>demo city</td>
<td>demo city</td>
</tr>
<tr>
<td>demo</td>
<td>demo</td>
</tr>
<tr>
<td>Uttar Pradesh</td>
<td>Uttar Pradesh</td>
</tr>
<tr>
<td>India</td>
<td>India</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product</th>
<th>Model</th>
<th>Quantity</th>
<th>Unit Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTC Touch HD</td>
<td>Product 1</td>
<td>1</td>
<td>$200.00</td>
<td>$200.00</td>
</tr>
<tr>
<td>Sold by Demo1</td>
<td>Status: Complete</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nikon D3600</td>
<td>Product 4</td>
<td>2</td>
<td>$10.00</td>
<td>$20.00</td>
</tr>
<tr>
<td>Sold by Demo1</td>
<td>Status: Complete</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Sub-Total: $220.00
Flat Shipping Rate: $5.00
Refunded (Manu Dev Madeshya): $200.00
Refunded (Manu Dev Madeshya): $5.00
Total: $5.00
Seller side process for return

- Login as a seller and go to Seller option menu and select orders.
- Click on view button to view all information related to order like refund.
Customer side process for return

- Login as a customer and go to customer menu and select Order History.
- Click on view button to view all information related to order like refund.
# Your Store

## Account

**Order Details**

- **Order ID:** #1234
- **Date Added:** 03/06/2019
- **Payment Method:** Cash On Delivery
- **Shipping Method:** Flat Shipping Rate

<table>
<thead>
<tr>
<th>Payment Address</th>
<th>Shipping Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demo customer</td>
<td>Demo customer</td>
</tr>
<tr>
<td>demo</td>
<td>demo</td>
</tr>
<tr>
<td>demo-424234234</td>
<td>demo</td>
</tr>
<tr>
<td>Uttar Pradesh,</td>
<td>Uttar Pradesh,</td>
</tr>
<tr>
<td>India</td>
<td>India</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Model</th>
<th>Quantity</th>
<th>Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>MacBook Air</td>
<td>Model17</td>
<td>1</td>
<td>$1,000.00</td>
<td>$1,000.00</td>
</tr>
<tr>
<td>Palm Treo Pro</td>
<td>Model2</td>
<td>1</td>
<td>$279.99</td>
<td>$279.99</td>
</tr>
<tr>
<td>iPhone</td>
<td>Model11</td>
<td>1</td>
<td>$101.00</td>
<td>$101.00</td>
</tr>
</tbody>
</table>

**Sub-Total:** $1,380.09

**Flat Shipping Rate:** $5.00

**Refunded (Demo 2 Store):** $1,000.00

**Refunded (Demo Store):** $279.99

**Total:** $100.00

## Order History

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Date Added</th>
<th>Status</th>
<th>Comment</th>
<th>Updated By</th>
</tr>
</thead>
<tbody>
<tr>
<td>MacBook Air</td>
<td>03/06/2019</td>
<td>Pending</td>
<td>Demo 2 Store</td>
<td>Demo 2 Store</td>
</tr>
<tr>
<td>Palm Treo Pro</td>
<td>03/06/2019</td>
<td>Pending</td>
<td>Admin</td>
<td>Admin</td>
</tr>
<tr>
<td>All</td>
<td>03/06/2019</td>
<td>Pending</td>
<td>Demo Store</td>
<td>Demo Store</td>
</tr>
</tbody>
</table>
Seller Discount Coupons

Admin can create discount coupons for seller product or can assign them also.

This functionality allows sellers to give discount on their products by which customers can save the money also.

How can admin assign coupons to sellers?

- Go to Admin > Marketing > Coupons.

- Click to add or edit button.

- Select the seller from auto-complete dropdown and fill all the other information of coupon then click to blue color save button.
- Seller name will be visible in the column.
How seller can create own discount coupon?

- Go to Seller Options > Click to seller coupons.

- Click to blue color add button.
 Fill all the information of coupon then click to continue button.

**Customer applying the seller coupon:**

- Add some seller product in the shopping cart then click to view cart button.
- Enter the coupon code in the coupon input box and then click to apply coupon.
The seller which has the product in cart the coupon will apply only on those products not on admin or other seller's products.

Whenever the customer has order the product with apply the coupon code. The coupon code will visible in the coupon history.

Edit the coupon code is apply by customers then click to history tab.

Setting Commission for Seller Groups
Admin can manage category-based commissions for seller groups.

Seller groups are user groups created by admin.
Admin can create different user groups and assign sellers into them, and can set different category-based commission for those groups.

Steps:
1. Go to ‘Multivendor-> Settings’.

   ![Multivendor Settings](image)

2. Category commission on any order will be assigned according to seller group if this option is enabled.

3. Admin can enable or disable Seller group commission. After that click on save button. You can check on page given below.

4. Go to ‘Multivendor-> Category Commission’.

5. Admin can add Fixed Commission along with Commission percent according to seller group.
## Category Commission

### Add Category Commission

<table>
<thead>
<tr>
<th>Category</th>
<th>Commission (%)</th>
<th>Fixed Commission</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>10.00%</td>
<td>10</td>
</tr>
</tbody>
</table>

**Seller Group**: Default

**Add** button

**Fixed Commission** button
Fixed Commission
- Go to Multivendor setting page> find “Fixed commission” option in General Tab.
- Enter the amount and click on save button.

How fixed global commission works
In PurpletreeMultivendor there are 3 types of commission working
- Category commission
- Seller store commission
- Global commission

Category commission
If category commission is applied on product and if category fixed commission exist, then global fixed commission would not add with total commission. If category fixed commission is blank, then global fixed commission would be added with total commission.

Seller store commission
If global fixed commission is set, then it would add with total commission.

Global commission
If global fix commission is set, then it would add with total commission.

Commission Invoice
Seller can view commission invoice.
9. Click on commission invoice link, you will get web page.
10. Click on View invoice button after that you will get print invoice page.

Seller & admin Message system

Admin and seller can communicate with each other through message system

Admin can send the message to a particular seller or to all sellers.

1. To send a message to the seller or sellers, the admin will have go to Multivendor > Sellers. Then click to chat icon button which is labeled as 2 in the screenshot.
2. After clicking to chat icon button then the page will redirect to message page type message to send to seller then click to send button as 2 labeled in screenshot.

3. Then the seller will receive the message on Seller Panel > Admin Messages. Admin message will appear in left or seller messages in right.
4. Whenever admin and seller have to talk to each other, in admin has an option called Seller Enquiries inside Multivendor > Seller Enquiries. Click to view button in Action column.

5. After clicking to view button then the page will redirect to message page all the messages to a seller will appear here.
6. When the message is send by admin then seller can reply from Seller Panel > Admin Messages.
If admin wants to send a message to all sellers, then go to Multivendor> Seller Enquiries click to "Send to all sellers" button.

7. Type your message here to send to all sellers.
Seller Notification of Orders and customer Enquiries

- Whenever customers order products of seller then the order notification will appear in seller dashboard.

- Click to order then page is redirect to orders page. Then the product notification will disappeared only the order which is click to view button.
Whenever customers enquire to seller then the customer enquiries notification will appear in seller dashboard.
• Click to customer enquiries then page is redirect to customer enquiries page. Then the enquiry notification will disappear which click to view all button.

• Orders + Customer enquiries total will appear on seller panel text on header of website.
Opencart Multi-Store Support

PurpletreeMultivendor fully supports Opencart Multi Store.

**Note:** if you want to use same license on multiple stores, the stores must be owned by the same person/company. If the stores serve different businesses, you will need separate license for every store. One license means one purchase of the extension.

One qty of the license can enable up to 5 multi-stores.

Examples:

- If 10 multi-stores are assigned to vendors, then 2 qty of license is required.
- If 22 multi-stores are assigned to vendors, then 5 licenses of Multivendor Extension are required.

Opencart Admin will have to inform Purpletree about all domains being used, and we will add all domains in the multivendor license as per this policy. Our detailed licensing policy is available [here](#).

When Multi Store feature of Opencart is enabled, then this extension has two modes of operation under Multivendor *Settings > General > Use domain wise stores*.

1. When domain-wise-stores setting is enabled in Multivendor

   This is used when admin wants to assign domains to vendors. In this case, admin can setup multiple domains in Opencart multi store, and assign them to vendors.

2. When domain-wise-stores setting is disabled in Multivendor

   In this case, admin makes use of multi store feature of Opencart, but does not want to assign independent domains to vendors. Vendors appear on that multi-store of Opencart, on which they registered originally.

1. **When domain-wise-stores setting is Disabled**

   If the seller registers on 1st Opencart multi-store, then seller login will work on that Opencart multi-store only. On the 2nd Opencart multi-store, the user can login with same credentials but only as a customer, not as a seller.

2. **When domain-wise-stores setting is Enabled**

   **IMPORTANT NOTE AND WARNING:**

   *If you do not have complete knowledge about setup of Opencart Multi-Store, do not enable “domain-wise-stores” in our extension. It can break your website.*

   Multiple websites/domains must already be configured in advance, using the Opencart multi-store setup, to use this feature of our extension.

   This requires advanced level of knowledge including web hosting domain mapping/setup knowledge.

   Opencart Multi-Store is a core Opencart feature, and not a new feature developed by us.
Please Follow the Opencart Documentation on how to create Multi-Store in Opencart:

To enable this, go to **Multivendor Settings** > **General** > **Use domain wise stores** option and set it to yes.

- Every vendor can have his own domain name if that domain name is added as a domain in Opencart multi-store setup.
- Admin can assign one vendor to one or multiple Opencart multi-store domains from the list of websites configured in Opencart multi-store setup. Any one Opencart multi-store can be assigned to more than one vendor as well.
- When a website/domain existing in the Opencart multi-store domains opens, our extension will show data of all vendors who are assigned to this Opencart multi-store domain.

**Assigning Opencart Multi-Store to a Seller**

Admin can assign multi store to seller.

- Go to **Multivendor** > **Stores** Menu
- Select **Assign Opencart Stores** tab
- Select one or more Opencart multi-stores using check box. After this is done, the seller is assigned to the website/domain corresponding to the selected Opencart multi-stores.
- Click on **save** button on top right corner of the screen.
• The Seller can login from any of its assigned websites/domains, and seller products would show only on the assigned stores.

Behavior of Multivendor when Domain-wise-Sellers options is enabled

In Multivendor, sellers are normal Opencart users, albeit with some additional capabilities.

1. Users can login as a seller only on assigned Opencart multi-store. On other Opencart multi-stores, user can login only as a customer.
   a) If Multiple Opencart multi-stores are assigned to a seller, then that seller can login from any Opencart multi-store and use all the functionality.
   b) Any seller created by admin is registered in default store only, if multiple Opencart multi-stores are not assigned to seller by the admin explicitly

2. Any Seller's products are visible only on the seller's assigned Opencart multi-stores and not on other Opencart multi-stores

3. Seller's blogs are shown on seller's assigned Opencart multi-store only, and not on other Opencart multi-stores

4. One seller can register using frontend registration form only from one Opencart multi-store. Same seller cannot register on other Opencart multi-stores using same email id. However, admin can still assign multiple Opencart multi-stores to the seller. In this case, the same user account can be used as a seller on both Opencart multi-stores.
Seller product Attribute

In the Seller Product attributes any seller can create their attributes for own products.

- To create attributes, go to Seller Options > Catalog > find Product Attributes menu > then click on it.

- Then go to Products Menu then Add or edit any product.
- Now, go to Attribute tab > Select any attribute from auto complete dropdown. In attributes the only the admin and seller attributes are visible other sellers attributes will not be visible in auto complete dropdown after that clicks to continue button.
Seller product Attribute Groups

- To create attributes groups, go to Seller Options > find Product Attributes Groups menu > then click on it.

Seller product Options

- To create attributes, go to Seller Options > Catalog > find Product Options menu > then click on it.
In options, here is the same criteria as attributes admin and seller can add the options. Othersellers’ options will not be visible in auto complete dropdown.

To assign the Options to product go to Products > Add/Edit any product then select option
Seller Custom Fields

Admin can add Seller custom fields for seller. All Seller custom fields show on seller register page. Seller can see all custom fields after successfully registration in store information page.

Adding Seller custom fields

- Go to admin navigation menu select Multivendor>Select Seller Custom Field option and click.
- After that you will reach on Seller Customer Fields page. Here Admin can seller all seller custom fields list. Add new seller custom fields, Edit available seller custom fields and Delete seller custom fields.

Find Plus symbol button and click you will reach on Seller Custom Fields form page. Here you can add information related to seller custom fields like Seller Custom Fields Name, Location, Type, Customer Group, Status, Sort order and Seller custom Fields Value Name.
- Location set option form the drop-down were you want to show the custom field on seller register page.
- After fill all required information click on save button.
Admin can also Edit and Delete Seller Custom Fields.
Admin can see all seller custom fields on seller store edit page.

Seller can see all seller custom fields on seller register page before successfully register as a seller.
<table>
<thead>
<tr>
<th>Seller Registration</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Personal details</strong></td>
<td></td>
</tr>
<tr>
<td><em>Store Name</em></td>
<td></td>
</tr>
<tr>
<td>Store Name</td>
<td></td>
</tr>
<tr>
<td>Store Phone</td>
<td></td>
</tr>
<tr>
<td>Store Phone</td>
<td></td>
</tr>
<tr>
<td>Store Logo</td>
<td></td>
</tr>
<tr>
<td>Browse</td>
<td>No file selected.</td>
</tr>
<tr>
<td>Store Address</td>
<td></td>
</tr>
<tr>
<td>Store Address</td>
<td></td>
</tr>
<tr>
<td>Store Country</td>
<td></td>
</tr>
<tr>
<td>--Please Select--</td>
<td></td>
</tr>
<tr>
<td>Store Region / State</td>
<td></td>
</tr>
<tr>
<td>--Please Select--</td>
<td></td>
</tr>
<tr>
<td>Store City</td>
<td></td>
</tr>
<tr>
<td>Store City</td>
<td></td>
</tr>
<tr>
<td>Store Postcode</td>
<td></td>
</tr>
<tr>
<td>Store Postcode</td>
<td></td>
</tr>
<tr>
<td>Store Shipping Policy</td>
<td></td>
</tr>
<tr>
<td>Store Shipping Policy</td>
<td></td>
</tr>
<tr>
<td>Store Return Policy</td>
<td></td>
</tr>
<tr>
<td>Store Return Policy</td>
<td></td>
</tr>
<tr>
<td><strong>Store Meta Keywords</strong></td>
<td></td>
</tr>
<tr>
<td>Store Meta Keywords</td>
<td></td>
</tr>
<tr>
<td>Store Meta Description</td>
<td></td>
</tr>
<tr>
<td>Store Meta Description</td>
<td></td>
</tr>
<tr>
<td>SEO URL For Store</td>
<td></td>
</tr>
<tr>
<td>SEO URL For Store</td>
<td></td>
</tr>
<tr>
<td>Facebook Link</td>
<td></td>
</tr>
<tr>
<td>Facebook Link</td>
<td></td>
</tr>
<tr>
<td>Google Plus Link</td>
<td></td>
</tr>
<tr>
<td>Google Plus Link</td>
<td></td>
</tr>
<tr>
<td>Twitter Link</td>
<td></td>
</tr>
<tr>
<td>Twitter Link</td>
<td></td>
</tr>
<tr>
<td>Instagram Link</td>
<td></td>
</tr>
<tr>
<td>Instagram Link</td>
<td></td>
</tr>
<tr>
<td>Pinterest Link</td>
<td></td>
</tr>
<tr>
<td>Pinterest Link</td>
<td></td>
</tr>
<tr>
<td>Website Link</td>
<td></td>
</tr>
<tr>
<td>Website Link</td>
<td></td>
</tr>
<tr>
<td>Whatsapp Number</td>
<td></td>
</tr>
<tr>
<td>Whatsapp Number</td>
<td></td>
</tr>
</tbody>
</table>

| **Seller experience** |  |
| ☐ 1 |  |
| ☐ 2 |  |
| ☐ 3 |  |

| **Seller type** |  |
| ☐ medical seller |  |
| ☐ Normal seller |  |
| ☐ vegetable seller |  |
When seller successfully registers then seller see all custom fields in store information page.
Hiding seller information for products

Go to Multivendor setting page. Set “Yes” for “Show seller name on product list” and “Show seller address on product list” options.
Hidingseller information on order success page

Go to Multivendor setting page. Set yes or no for “Show seller information on order success page” option.
Seller order status changed by customer

Every order has 2 status – Seller status and Admin status. An order is assumed completed when first the seller status is updated to Complete by seller and then admin status is set to complete by admin.
Customer can also change seller order status, if allowed from settings.
Go to Multivendor setting page. Set yes for Allow customer to manage orders option.
To manage order status, customer after login goes to order history page. Clicks on view button. Customer will reach on order detail page. Here customer can change seller order status.
Hyperlocal Feature

In our Hyperlocal system, seller and seller's products are shown geographical area-wise, if any user opens the store and selects an area, seller and seller's product show on the basis of the selected area. Users can again change the area for the website according to need.

- Go to Multivendor menu and select Seller Area.
- You will reach on Seller Area list page
- Here you can add, edit and delete Seller Area

Assigning areas to sellers from Admin
Go to Multivendor menu select store> Click on edit store button.
You will reach on seller store edit page.
Find Seller Areas option
If you have selected "All" then all area selected.

If you have selected "Selected" then go to seller area input box.

Click on seller area input box and select multiple area for seller store
After that click on save button.

How sellers can assign Areas

Seller can also select area for her/his store.
Login as a seller
Go to Store information option in seller panel and click on it.
• You will reach on Store information page.
• Here you find “Seller Areas” option.
• If you have selected “All” then all area selected.

If you have selected “Selected” then go to seller area input box.

Click on seller area input box and select multiple area for seller store
After that click on save button.

Selecting area at the time of seller registration

User can also select area on the time of seller registration.
• Go to seller register page.
• Fill the personal detail form and click on next button.
• You will reach on seller information form page.
• Here you can find seller areas option.
• If you have selected “All” then all area selected
• If you have selected “Selected” then go to seller area input box.
• Click on seller area input box and select multiple area for seller store
• After that fill all information and submit your seller register form.
Configuring Hyperlocal options

- First of all login admin panel > go to Multivendor setting > select general tab > find "Hyper Local" tab.
- After that find "Hyperlocal" option and set yes for Hyper local.
- After set yes for Hyper local visible "Heading in Popup for Hyperlocal", here enter the heading for Hyperlocal popup
- After that "Area Display" option will appear here, we will get here three area display options "Dropdown", "Text Box with Suggestion" and "Text Box".
- We have to choose any one option. If you have selected "Text box with suggestion" you will get a display area popup text box with Suggestion.
- Thereafter "Area Selection Mandatory." Option, if set "Yes" then user must be select area after that popup close. Close button not visible on Hyperlocal popup. If set "No" then close button visible on Hyperlocal popup and area selection not mandatory. After that click on save button.
- If you want to go on Seller Area page, then click on "Go to Seller Area "button.
When Website home page is open then Area selection popup is open.

**Area Display at Homepage**

1. **Dropdown:**
   
   Customer can select area option from dropdown here.

   ![Dropdown Example](image)

   - After that you can select area by using drop-down. All seller and seller product are shown based of this area.
• If customer wants to change area then click on current area then popup is open.

• If area selection is not mandatory and user click on close button.

• After that “All” area selected automatically in Hyperlocal popup.
2. **Text box with suggestion**

As soon as the customer clicks in the search area. The customer will get all the enabled area and the customer can select the desired area option here. After that click on OK button. If option matches any seller area then store and store product will appear of those sellers here otherwise you will get message "No seller is available for this area".

![Image of text box with suggestion](image-url)

3. **Text box**

The customer can type the text in the search area and then click on the OK button. If the text typed matched with the seller areas, the store and store product will appear on the webpage. Otherwise you will get message "No seller is available for this area".

Note: -Hitting “Enter” button also be equal to clicking the ok button and accordingly will display results.
Support

If you face any issues, please open a support ticket on
https://www.helpdesk.purpletreesoftware.com with following information:

1. Order Id
2. Admin Login (username, password, URL)
3. Cpanel Access (or) FTP with storage directory permissions