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I. Short Answers [ 2 mark questions ] 
1. Define GUI. 

A GUI (graphical user interface) is a system of interactive visual components for computer 

software. A GUI displays objects that convey information, and represent actions that can be taken 

by the user. 

2. List any four input devices. 

• Keyboard is the most common and very popular input device which helps to input data to 

the computer. 

• Mouse is the most popular pointing device. 

• Joystick is also a pointing device, which is used to move the cursor position on a monitor 

screen. 

• Track ball is an input device that is mostly used in notebook or laptop computer, instead of a 

mouse. 

3. Define Word Processor. 

A word processor is software that allows users to create, edit, and print documents. It enables you to 

write text, store it electronically, display it on a screen, modify it by entering commands and 

characters from the keyboard, and print it. Ex: MS Word. 

4. Define Operating system. List any two types of OS software. 

An operating system is system software that controls the working of computer hardware and 

software.  Two types are : 

o Single user operating system : MS-DOS, Windows-95 

o Multi user operating system : Linux, Unix, Windows-2000 

5. Name the feature of MS Office that saves the document automatically after certain period of 

interval. 

AUTO SAVE – feature of MS Office saves the document automatically. 

Steps : My Computer ->C: -> Documents & Setting -> User folder-> Application Data -> 

Microsoft -> <file name> 
 

6. List any four fonts style. 

Regular font-weight has the typeface or normal typed characters. 

Bold font-weight has the same style as a regular font, with thicker letters. 

Italic font is a left-to-right slanted version of your typeface’s regular font. 

Bold italic is both slanted & thicker version of your typeface. 

7. How to set password for a document in Microsoft word ? 

1. Open the Word(Excel or PowerPoint) document.  

2. Click on File -> Info -> Protect document menu 

3. Select the Encrypt with password option 

4. Type password -> Click OK  

8. List any two editing features of Word processor. 

o Cut – Copy – Paste : allow cut, copy and paste text or images directly into the document, and 

move them around, without having to rewrite everything. 

o Undo – Redo : Undo reverse the process/action done recently. Redo reverse the Undo process. 
 

9. Name different document views in Microsoft word. 

o Web. Microsoft Word's Web view lets you see how your document will look as a website.  

o Print. Ideal when setting margins and formatting your Word document for printing  

o Outline. The Outline view adds bullets, nested levels and indented lines within the document. 

o Normal. The Normal view, Microsoft Word's default view, is ideal when working with text 

and graphics . 

https://www.webopedia.com/definitions/document/
https://www.webopedia.com/definitions/command/
https://www.toppr.com/guides/computer-aptitude-and-knowledge/computer-applications/operating-systems/
https://www.toppr.com/guides/computer-aptitude-and-knowledge/basics-of-computers/history-of-computers/


10. List any two applications of Spread sheet. 

• Statistical analysis : Spreadsheets provide the user with a variety of statistical functions 

that will enable him to perform both simple and complex statistical operations such as 

computing the mean, standard deviation, average, mode etc. 

• Accounting : Spread sheets are known to be a useful tool to the accountants for recording 

and analyzing financial transaction such as computing totals, consolidating financial records 

as well as predicting future business trends 

• Mathematical and scientific : These involves the use of spreadsheets to solve 

mathematical and scientific problems such as arithmetic and trigonometric. 

11. What do you mean by Autofill. 

Excel AutoFill Option allows you to create an entire column or rows of data which are based on the 

values from other cells. In other words, this feature fills cells with data that follows a pattern or that 

are based on data in other cells. 

12. List any two Statistical functions in MS-Excel 

(a) Count - Used to count the number of cells containing a number.  

              Ex:  =count(A1 : B10) 

(b) MAX – Used to find the largest / maximum value in the range of cells. 

               Ex : =max(E10 : G25) 

13. What is Format painter? Draw the icon. 

The Format Painter tool allows you to copy the formatting of one cell to another cell w.r.t MS 

EXCEL or Copy the formatting features (such font style and type) into another text w.r.t MS 

WORD. 

 
14. What do you mean by cell in Microsoft Excel worksheet ? 

A cell is the intersection where a row and a column meet on a spreadsheet that starts with cell A1. 

 A B C ….. 

1     

2     

. 

. 

    

 

15. Name the data formats in Microsoft Excel. 

Different types of data formats are available in Microsoft Excel for data Storage. 

• Number – Stores data as a number (with decimal places and separators) 

• Currency – Stores data in the form of currency. (select country currency) 

• Date – Data is stored as dates. (formats like dd-mm-yyyy, dd-mon,yyyy,……) 

• Percentage – Stores numbers as a percentage (with decimal places) 

• Text Formats – Stores data as string of texts. (even number is stored as text) 

16. What is relative cell address ? 

Relative references in Excel are cell references that change when the formula is copied to any other 

cell or any other worksheet. 

For instance, in cell A1, we have “=B1+C1.” On copying this formula to cell B2, the formula 

becomes “=C2+D2.” 
 

17.  how do you enter the given expression in the formula bar : 

 

 

 

 A B C 

1 2 8 1 

2    

=SQRT((B1*B1) - 4*A1*C1) 

CELL with address 

B2 



 

18. List any for types of charts. 

• Line Graph : The most common, simplest, and classic type of chart graph is the line graph. This is 

the perfect solution for showing multiple series of closely related series of data. 

• Bar Graph : Bars (or columns) are the best types of graphs for presenting a single data series 

• Scatter Plot : The scatterplot is excellent for showing the relationship between two data series and 

determining their correlation 

• Pie Chart : Pie charts illustrate the percentage breakdown of a small number of data points, they 

can be very effective. 

19. Give any four Financial functions in MS-Excel. 

PV : Calculates the present value of an investment (i.e. the total amount that a series of future 

periodic constant payments is worth now) Ex : =PV( 5%/12, 60, 1000 ) 

FV : Calculates the future value of an investment with periodic constant payments and a constant 

interest rate Ex: =FV( 5%/12, 60, -1000 ) 

PMT : Calculates the payments required to reduce a loan, from a supplied present value to a 

specified future value Ex : =PMT( 5%/12, 60, 50000 ) 

RATE : Calculates the interest rate required to pay off a specified amount of a loan, or reach a 

target amount on an investment over a given period Ex : =RATE( 60, -1000, 50000 ) 

20. List different types of slide view 

Normal view : Normal view is the main editing view, where you write and design your 

presentations. 

Slide Sorter : Slide Sorter view gives you a view of your slides in thumbnail form. This view 

makes it easy for you to sort and organize the sequence of your slides as you create your 

presentation 

Reading view :Use reading view to deliver your presentation not to an audience (via a large screen, 

for example), but instead to someone viewing your presentation on their own computer 

Slide Show :  Use Slide Show view to deliver your presentation to your audience. Slide Show view 

occupies the full computer screen, exactly like an actual presentation 

21. “Graphical presentation helps to understand the concept better”. Give any two reason. 

• A good visualization tells a story, removing the noise from data and highlighting the useful 

information in the forms of charts, graphs, and diagrams draw and keep the attention of the 

listeners.  

• a convenient way to compare different sets of data. 

           Hence graphical presentation are better than text data in many cases. 

22. Define DBMS.   

A database management system (DBMS) is system software for creating and managing databases. 

A DBMS makes it possible for end users to create, protect, read, update and delete data in 

a database.  

23. List any four data types for the fields.  

Type of Data Description 

Short Text 
Text or combinations of text and numbers, including numbers that do not require 

calculating (e.g. phone numbers). 

Long Text Lengthy text or combinations of text and numbers. 

Number Numeric data used in mathematical calculations. 

https://www.techtarget.com/searchdatamanagement/definition/database


Date/Time Date and time values for the years 100 through 9999. 

Currency 
Currency values and numeric data used in mathematical calculations involving 

data with one to four decimal places. 

AutoNumber 
A unique sequential (incremented by 1) number or random number assigned by 

Microsoft Access whenever a new record is added to a table. 

Yes/No 
Yes and No values and fields that contain only one of two values (Yes/No, 

True/False, or On/Off). 

24. Define Database. 

A database is a collection of related data which represents some aspect of the real world. A database 

system is designed to be built and populated with data for a certain task. 

 

II. Long  Answers [ 5 mark questions ] 
1. With neat diagram, Explain different components of Computer. 

 
Input Unit :The input unit consists of input devices that are attached to the computer. Some of the 

common input devices are keyboard, mouse, joystick, scanner etc. 

Central Processing Unit (CPU) : The CPU is called the brain of the computer because it is the 

control center of the computer. The CPU has three main components which are responsible for 

different functions –  

• Arithmetic Logic Unit (ALU) - performs mathematical calculations and takes logical decisions. 

• Control Unit (CU) - coordinates and controls the data flow in and out of CPU   

• Memory registers - used to store the data which is directly used by the processor 
Output Unit : The output unit consists of output devices that are attached with the computer. 

 

2. Explain basic editing and formatting features of Microsoft word. 
Editing a Document : Making changes in already typed text is called Editing. 

Some of the editing features are : 

• Copying and Paste text 

• Cut and Paste text 

• Drag and Drop text 

• Undo and Redo  



Formatting a Document : The Process of changing the appearance and arrangement of the text is 

called Formatting. 

Some of the formatting features are : 

• Changing the Font style 

• Highlight text 

• Bold Italic Underline  

• Changing the text case (upper or lower) 

• Changing text alignment 

• Adding text effects etc… 

 

3. Write a note on Mail merge features of Microsoft Word. 
Mail Merge is most often used to print or email form letters to multiple recipients. Using Mail 

Merge, you can easily customize form letters for individual recipients. Mail merge is also used to 

create envelopes or labels in bulk. 

General steps to use Mail merge feature in MS-WORD 

1. In a blank Microsoft Word document, click on the Mailings tab, and in the Start Mail Merge 

group, click Start Mail Merge . 

2. Click Step-by-Step Mail Merge Wizard . 

3. Select your document type. 

4. Select the starting document. 

5. Select recipients. 

6. Write the letter and add custom fields. 

 

4. Explain the steps to create and design (a) Drop cap (b) Water mark (c) Organization chart (d) 

Hyperlink (e ) Add quick part in MS-Word. 

(a) Drop cap :  (1) Click in the paragraph to which you want to add a Drop Cap. 

                         (2) On the Insert tab, in the Text group, choose one of the drop-cap options. 

 

(b) Water mark :  (1) Open new document. 

                          (2) Click on Design tab -> Watermark 

 

(c) Organization chart :  (1) Open new document 

                         (2) On the Insert tab, Click SmartArt -> choose the graphic type. 

 

(d) Hyperlink  :  (1) Open new document -> Select the text you want to create link 

                         (2) On the Insert tab, Click link -> enter address field & text to display 

 

(e) Add quick part :  (1)Open a document  you want to add Quick parts 

                         (2) On the Insert tab, in the Text group, choose Quick parts 

                
5. Explain various statistical functions in Microsoft Excel. 

Function Purpose Syntax 

MIN Returns the minimum value in a list of 

arguments 

MIN(number1, [number2], ...) 

MAX Returns the largest value in a set of values. MAX(number1, [number2], ...) 



COUNT The COUNT function counts the number of 

cells that 

contain numbers, and counts numbers within 

the list of arguments 

COUNT(value1, [value2], ...) 

COUNTIF The COUNTIF function counts the number 

of cells 

within a range that meet a single criterion 

that you specify. 

COUNTIF(range, criteria) 

COUNTA The COUNTA function counts the number 

of cells that are not empty in a range (range: 

Two or more cells on a sheet. The cells in a 

range can be adjacent or 

nonadjacent.). 

COUNTA(value1, [value2], ...) 

STDEV The standard deviation is a measure of how 

widely 

values are dispersed from the average value. 

STDEV(number1,number2,…..) 

MEAN Returns the geometric mean of an array or 

range of positive data 

 

Returns the harmonic mean of a data set. The 

harmonic mean is the reciprocal of the 

arithmetic mean of reciprocals. 

GEOMEAN(number1, [number2], ...) 

 

 

HARMEAN(number1, [number2], ...) 

MODE Returns the most frequently occurring, or 

repetitive, 

value in an array or range of data. 

MODE(number1,number2,….) 

MEDIAN Returns the median of the given numbers. 

The median is 

the number in the middle of a set of 

numbers. 

MEDIAN(number1, [number2], ...) 

VARIANCE Calculates variance based on the list of 

values 

VAR(number1,[number2],...]) 

CORRELATION Returns the correlation coefficient of the 

array1 and 

array2 cell ranges. 

CORREL(array1, array2) 

PERCENTILE Returns the k-th percentile of values in a 

range, where k is in the range 0..1, exclusive. 

PERCENTILE(array,k) 

QUARTILE Returns the quartile of the data set, based on 

percentile values from 0..1, exclusive. 

QUARTILE(array,quart) 

IF quart 0-> min, 1->first quartile, 2-

>second quartile, 3->third quartile, 4-

>max 

 

 

 

 

 

 

 



6. Write a note on creating chart / Graphs in Microsoft Excel. 
Steps to create chart : (Ex. Bar chart) 

1. Select the range from the worksheet 

 

 

 

 

 

 

2. On the Insert tab -> Chart group -> select the type of chart (Bar) 

3. Result : 

 

 

Other features are : 

• Change the chart type : Design chart -> chart type -> click on the type of chart you wish to change 

• Add data labels  

• Switch Row/Columns. 

  

7. How do you add pictures and shapes to a worksheet. 
Steps to add pictures and shapes to a worksheet : 

• Go to the ‘Insert’ tab. 

• Click the ‘Shapes’  / ‘Pictures’ option under the ‘Illustrations’ group. 

• Select any shape from the drop-down list. 

• Left click on the spreadsheet to drag and create your shape. 

▪ [For pictures] Select the pictures from the drive / path 

• Right-click on the shape / pictures. 

• In the context menu that appears,  

▪ click on the ‘Format Shape’ option-> Edit the shapes 

▪ click on the ‘Format pictures’ option-> Edit the pictures. 

 

8. Discuss slide transition and animation setup features of Microsoft PowerPoint. 
Slide Transition specifies how the slide enters and gets itself displayed on the computer screen. 

slide transition can be added. 

• Click on  Transition tab on the Ribbon. 

• Select from a wide range of transition effects  

• Under Timing command group, set the following 

o Sound 

o Duration 

o Apply to all. 

• Advance Slide-(Default is set to mouse click. Change that to “After” and set the time duration ) 

• Click the Preview button to preview it. 
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Animation setup : 

• Select the object to apply animation. 

• Click Animation pane command under Advanced Animation command group. 

• Then under Timing command group, uncheck the On click and select After Previous, and then set the 

duration timing as well. 

• Finally, click on Preview command  

 

9. Explain any 5 special features of Microsoft Power point. 
PowerPoint is a highly innovative and versatile program that can ensure a successful 

communication in front of potential viewers. There are multiple features that are available in MS 

PowerPoint which can customise and optimize a presentation. Five among them are : 

• Slide Layout 

Multiple options and layouts are available based on which a presentation can be created. This option 

is available under the “Home” section and one can select from the multiple layout options provided. 

• Insert – Clipart, Video, Audio, etc. 

Under the “Insert” category, multiple options are available where one can choose what feature they 

want to insert in their presentation. This may include images, audio, video, header, footer, symbols, 

shapes, etc.  
• Slide Design 

MS PowerPoint has various themes using which background colour and designs or textures can be 

added to a slide. This makes the presentation more colourful and attracts the attention of the people 

looking at it. 
• Animations 

During the slide show, the slides appear on the screen one after the other. In case, one wants to add 

some animations to the way in which a slide presents itself, they can refer to the “Animations” 

category.  

• Adding APPS to Powerpoint 

APPS can be added to PowerPoint by going to the Office Store via browser, select an app and login 

with your Microsoft account. 

 

10. What is a process of creating table and inserting record in Microsoft Access. 
Steps to create table (Designer view) 

• Select Create tab -> Click Table from the ribbon 

( Field tab with ID is created automatically) 

• Click on “Click to Add” to add more fields and assign data types. 

• By default field names will be Field1, Field2 etc.. it can be renamed Right click on field -> 

select Rename Field option . 

• Click on Save 

Inserting records : 

• Open the desired table in datasheet view 

• Click the “New Record” button at the right end of the record navigation button group 

•  Enter the information into the fields in the “New Record” row 

• Bottommost row in the datasheet view displays the asterisk [*] at the left end of the row. 

• Close the table when you are finished adding records. 

SQL View : 

           Select the Query Design from the Create tab and write query as : 

(a)       CREATE TABLE Student 

             (SID int PRIMARY KEY, 

              Name CHAR(50)); 

(b)        INSERT into Student(SID,Name) values (1234,”ABC”); 

 

 

 

https://learn.filtered.com/microsoft-powerpoint
https://store.office.com/en-us/appshome.aspx?ui=en-US&rs=en-US&ad=US


 

*NOTE : 

 REFER COMPUTER LAB MANUAL PROBLEMS 

FOR LONG ANSWES. 

Sample Q.formats for problem oriented questions  
 

11. Do as (Write the steps and formula for each) 

     (a) Total cost of Postage charges. 

     (b) Average amount spent on cleaning 

     (c ) Max. amount spent on Coffee/Tea 

     (d) steps to draw bar graph for Month vs Stationery 

 A B C D E 

1 Month Postage Coffee/Tea Cleaning Stationery 

2 January 13.5 11 14 15.75 

3 February 7.65 2.5 14 17.38 

4 March 19.38 3.45 14 20.75 

5 April 9.23 4.15 17 9.5 

6 May 11.68 2.17 17 12.45 
 

12. Do as (Write the steps and formula for each) 

     (a) Total marks and percentage of each student 

     (b) calculate grade (i) Percentage >=90   Grade=’A’ 

                                    (ii) Percentage >=80 && Percentage < 90  Grade = ‘B’ 

                                    (iii) Percentage >=70 && Percentage < 80 Grade = ‘C’ 

                                    (iv) Percentage >=60 && Percentage < 70 Grade = ‘D’ 

                                    (v)  Percentage < 60 Grade = ‘E’ 

     (c ) Steps to apply conditional formatting for Grade. 

     (d) steps to draw bar pie chart depicting % of Grade. 

 A B C D E F G H 

1 Regno Name Mark-1 Mark-2 Mark-3 Total Percentage Grade 

2         

3         

4         

5         

6         
 

13. Do as (Write the steps and formula for each) 

     (a) Total sale for each sector and each month. 

     (b) Steps to apply conditional formatting for those salary > 15000 

     (c) steps to draw column chart to show sector wise data for all four months 

     (d) Create a 3-D pie chart to show sales in Jan in all sectors. 

 A B C D E 

1 Sector / 

Month 

Jan Feb Mar April 

2 Sector 30 12000 17000 14000 15000 

3 Sector 22 14000 18000 15000 16000 

4 Sector 23 15000 19000 16000 17000 

5 Sector 15 16000 12000 17000 18000 
 

 



14. Do as (Write the steps and formula for each) 
 

Calculate Cumulative Frequency for the given data and generate Scatter graph. 

Item Price Frequency 

1-10 20 

11-20 21 

21-30 13 

31-40 8 

41-50 4 

(a) Create the above table and save as CF.xls 

(b) Insert a new column Cumulative Frequency 

(c) Calculate Cumulative Frequency using appropriate formula 

(d) Select Item Price and Cumulative Frequency Column only and generate Scatter Graph. 

 

 

15. Do as (Write Query for each) 

Field Name Data 

type 

Field 

size/format 

ID Number   

Name   

Surname   

Telephone no   

DOB   

Stipend   

 

(a) Create a query, showing all the records. 

(b) Create a query, showing all fields of those students 

who have particular surname. 

(c) Create a query, showing all fields who has born after 

2000. 

(d) Create a query, delete the records who have 

particular surname. 

(e) Create a query, to display the records in the 

ascending order of surname. 


